summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Dent <cdent@anticdent.org>2018-10-24 13:52:58 +0100
committerChris Dent <cdent@anticdent.org>2018-10-24 13:52:58 +0100
commit9ceef07267ba83ea5c00533f85f9edf9ba38cd71 (patch)
treea629a6ee15e6639a77f9f9b5564a0b6357f05b7b
parent3363151d41ea7ffebd8b79e236c191d6f659c78a (diff)
downloadpaste-git-9ceef07267ba83ea5c00533f85f9edf9ba38cd71.tar.gz
Prepare a 3.0.0 release3.0.0
This is for the sake of getting something out there, including fixes to get stuff working with Python 3.7.
-rw-r--r--docs/conf.py4
-rw-r--r--docs/news.txt7
-rw-r--r--setup.cfg2
-rw-r--r--setup.py16
4 files changed, 16 insertions, 13 deletions
diff --git a/docs/conf.py b/docs/conf.py
index a2a2f86..59194e8 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -40,9 +40,9 @@ copyright = '2008, Ian Bicking'
# other places throughout the built documents.
#
# The short X.Y version.
-version = '1.7'
+version = '3.0'
# The full version, including alpha/beta/rc tags.
-release = '1.7.5.1'
+release = '3.0.0'
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
diff --git a/docs/news.txt b/docs/news.txt
index d17001c..2255386 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -3,6 +3,13 @@ News
.. contents::
+3.0.0
+-----
+
+* Fixes for use with Python 3.7, mostly to do with ``StopIteration``.
+
+* Moving to https://github.com/cdent/paste to keep things maintained.
+
2.0.3
-----
diff --git a/setup.cfg b/setup.cfg
index e60fe4f..00ae880 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -6,3 +6,5 @@ tag_svn_revision = 0
[aliases]
distribute = register sdist bdist_egg upload pudge publish
+[bdist_wheel]
+universal=1
diff --git a/setup.py b/setup.py
index ab8ed29..84df215 100644
--- a/setup.py
+++ b/setup.py
@@ -7,18 +7,12 @@
# the SCM (Mercurial): update MANIFEST.in if needed
# - update changelog: docs/news.txt
#
-# TODO(cdent): Update for github.
-#
-# - hg ci
-# - hg tag VERSION
-# - hg push
-# - python2 setup.py register sdist bdist_wheel upload
-# - python3 setup.py bdist_wheel upload
-#
-# - increment version in setup.py (__version__)
-# - hg ci && hg push
+# - git commit
+# - git tag -s VERSION
+# - git push
+# - python setup.py sdist bdist_wheel upload --sign
-__version__ = '2.0.3'
+__version__ = '3.0.0'
from setuptools import setup, find_packages
import sys, os