summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2018-11-03 18:08:02 +0800
committerChris Dent <chris.dent@gmail.com>2018-11-03 10:08:02 +0000
commitae93da351011b07e5867c084f43350fe3bb84d6b (patch)
tree6daa6c372bffcede3f273ee0a155dd9015fda977
parent5a4c717b02144fc501eab5271495ca7fa9d0c3f7 (diff)
downloadpaste-git-ae93da351011b07e5867c084f43350fe3bb84d6b.tar.gz
Depend on pytest instead of nose (#13)
-rw-r--r--setup.cfg1
-rw-r--r--setup.py4
2 files changed, 3 insertions, 2 deletions
diff --git a/setup.cfg b/setup.cfg
index 7300c5b..20def47 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,6 +5,7 @@ tag_svn_revision = 0
[aliases]
distribute = register sdist bdist_egg upload pudge publish
+test = pytest
[bdist_wheel]
universal=1
diff --git a/setup.py b/setup.py
index 8f10069..9bd65d7 100644
--- a/setup.py
+++ b/setup.py
@@ -52,9 +52,9 @@ setup(name="Paste",
exclude_directories=finddata.standard_exclude_directories + ('tests',)),
namespace_packages=['paste'],
zip_safe=False,
- test_suite='nose.collector',
+ setup_requires=['pytest-runner'],
install_requires=['six>=1.4.0'],
- tests_require=['nose>=0.11'],
+ tests_require=['pytest'],
extras_require={
'subprocess': [],
'hotshot': [],