summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Bicking <ian@ianbicking.org>2005-08-22 22:16:34 +0000
committerIan Bicking <ian@ianbicking.org>2005-08-22 22:16:34 +0000
commit1d59624c76053f67be84769e15771c633d405a7b (patch)
tree751366387d4c89e93b874f626724f4b3ece2ff49
parentfe3cba5eded1fc23371784d7d8571f0bdfcb4117 (diff)
downloadpaste-git-1d59624c76053f67be84769e15771c633d405a7b.tar.gz
paste.deployified recursive
-rw-r--r--paste/recursive.py2
-rw-r--r--setup.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/paste/recursive.py b/paste/recursive.py
index f21c91a..93a5776 100644
--- a/paste/recursive.py
+++ b/paste/recursive.py
@@ -15,7 +15,7 @@ class RecursiveMiddleware(object):
``paste.recursive.include`` environmental keys.
"""
- def __init__(self, application):
+ def __init__(self, application, global_conf=None):
self.application = application
def __call__(self, environ, start_response):
diff --git a/setup.py b/setup.py
index b3db3d6..ba55844 100644
--- a/setup.py
+++ b/setup.py
@@ -63,6 +63,7 @@ functionality.
login=paste.login:middleware
printdebug=paste.printdebug:PrintDebugMiddleware
profile=paste.profilemiddleware:ProfileMiddleware
+ recursive=paste.recursive:RecursiveMiddleware
""",
},
)