summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Bicking <ian@ianbicking.org>2005-08-22 22:06:47 +0000
committerIan Bicking <ian@ianbicking.org>2005-08-22 22:06:47 +0000
commit26b8ad72fb1df14bf7f9ae5bdc54f5617ead9d3a (patch)
tree5c4f1754399539427c284984d6ce934cb2fc9042
parent0d8ce0acc2d36ffc6343dc3cd31bc982238c3c44 (diff)
downloadpaste-git-26b8ad72fb1df14bf7f9ae5bdc54f5617ead9d3a.tar.gz
paste.deployified printdebug
-rw-r--r--paste/printdebug.py6
-rw-r--r--setup.py1
2 files changed, 4 insertions, 3 deletions
diff --git a/paste/printdebug.py b/paste/printdebug.py
index 83250ab..95630e3 100644
--- a/paste/printdebug.py
+++ b/paste/printdebug.py
@@ -37,8 +37,8 @@ class PrintDebugMiddleware(object):
'<b style="border-bottom: 1px solid #000">Log messages</b><br>'
'%s</pre>')
- def __init__(self, subapp, force_content_type=False):
- self.subapp = subapp
+ def __init__(self, app, global_conf=None, force_content_type=False):
+ self.app = app
self.force_content_type = force_content_type
def __call__(self, environ, start_response):
@@ -57,7 +57,7 @@ class PrintDebugMiddleware(object):
try:
threadedprint.register(replacement_stdout)
status, headers, body = wsgilib.capture_output(
- environ, start_response, self.subapp)
+ environ, start_response, self.app)
if status is None:
# Some error occurred
status = '500 Server Error'
diff --git a/setup.py b/setup.py
index 70b86ec..4162480 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,7 @@ functionality.
httpexceptions=paste.httpexceptions:middleware
lint=paste.lint:middleware
login=paste.login:middleware
+ printdebug=paste.printdebug:PrintDebugMiddleware
""",
},
)