summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Bicking <ian@ianbicking.org>2005-08-22 21:59:18 +0000
committerIan Bicking <ian@ianbicking.org>2005-08-22 21:59:18 +0000
commit3d78accae2b421591daae5d1c10f948f2c070436 (patch)
treed4a7bc3a780dbc9de6c0e2e9cd576412fa0a6be2
parent6be5aafda33852aa667f95ace3214e0c696c85b9 (diff)
downloadpaste-git-3d78accae2b421591daae5d1c10f948f2c070436.tar.gz
paste.deployified httpexceptions
-rw-r--r--paste/httpexceptions.py2
-rw-r--r--setup.py1
2 files changed, 2 insertions, 1 deletions
diff --git a/paste/httpexceptions.py b/paste/httpexceptions.py
index 16fca6f..5f8405f 100644
--- a/paste/httpexceptions.py
+++ b/paste/httpexceptions.py
@@ -211,7 +211,7 @@ def get_exception(code):
## Middleware implementation:
############################################################
-def middleware(application):
+def middleware(application, global_conf):
"""
This middleware catches any exceptions (which are subclasses of
diff --git a/setup.py b/setup.py
index 2efd2f5..5abc952 100644
--- a/setup.py
+++ b/setup.py
@@ -57,6 +57,7 @@ functionality.
cgitb=paste.cgitb_catcher:CgitbMiddleware
flup_session=paste.flup_session:SessionMiddleware
gzip=paste.gzipper:middleware
+ httpexceptions=paste.httpexceptions:middleware
""",
},
)