summaryrefslogtreecommitdiff
path: root/paste
diff options
context:
space:
mode:
authorIan Bicking <ian@ianbicking.org>2005-06-30 20:48:10 +0000
committerIan Bicking <ian@ianbicking.org>2005-06-30 20:48:10 +0000
commitef4311128cb9d4a671d02a5eb76d489a130c1c52 (patch)
treef76e6db73740ce2331d3ac51ac545a53366c54ad /paste
parente05b4de439d898d9316e223b7dbee486310e19d8 (diff)
downloadpaste-git-ef4311128cb9d4a671d02a5eb76d489a130c1c52.tar.gz
Patch from Thomas Jenkins (ticket #17), fixing paster list
Diffstat (limited to 'paste')
-rw-r--r--paste/app_setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/paste/app_setup.py b/paste/app_setup.py
index bdbdded..fddc756 100644
--- a/paste/app_setup.py
+++ b/paste/app_setup.py
@@ -258,17 +258,17 @@ class CommandList(Command):
continue
if not self.options.verbose:
print '%s: %s\n' % (
- name, self.template_description().splitlines()[0])
+ name, self.template_description(dir).splitlines()[0])
else:
return '%s: %s\n' % (
- self.name, self.template_description())
+ self.name, self.template_description(dir))
# @@: for verbosity >= 2 we should give lots of metadata
any = True
if not any:
print 'No application templates found'
- def template_description(self):
- f = open(os.path.join(self.template_dir, 'description.txt'))
+ def template_description(self, dir):
+ f = open(os.path.join(dir, 'description.txt'))
content = f.read().strip()
f.close()
return content