summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Dent <cdent@anticdent.org>2018-10-24 13:52:58 +0100
committerChris Dent <cdent@anticdent.org>2018-10-24 13:52:58 +0100
commit9ceef07267ba83ea5c00533f85f9edf9ba38cd71 (patch)
treea629a6ee15e6639a77f9f9b5564a0b6357f05b7b /setup.py
parent3363151d41ea7ffebd8b79e236c191d6f659c78a (diff)
downloadpaste-git-9ceef07267ba83ea5c00533f85f9edf9ba38cd71.tar.gz
Prepare a 3.0.0 release3.0.0
This is for the sake of getting something out there, including fixes to get stuff working with Python 3.7.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 5 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index ab8ed29..84df215 100644
--- a/setup.py
+++ b/setup.py
@@ -7,18 +7,12 @@
# the SCM (Mercurial): update MANIFEST.in if needed
# - update changelog: docs/news.txt
#
-# TODO(cdent): Update for github.
-#
-# - hg ci
-# - hg tag VERSION
-# - hg push
-# - python2 setup.py register sdist bdist_wheel upload
-# - python3 setup.py bdist_wheel upload
-#
-# - increment version in setup.py (__version__)
-# - hg ci && hg push
+# - git commit
+# - git tag -s VERSION
+# - git push
+# - python setup.py sdist bdist_wheel upload --sign
-__version__ = '2.0.3'
+__version__ = '3.0.0'
from setuptools import setup, find_packages
import sys, os