diff options
author | Colin Watson <cjwatson@ubuntu.com> | 2020-01-27 13:32:09 +0000 |
---|---|---|
committer | Chris Dent <cdent@anticdent.org> | 2020-01-27 13:32:09 +0000 |
commit | e9827316dfb827a8005dbfc9b370edd7d330773e (patch) | |
tree | e2e5985d71970f8a23e3ed5807ee98cfb7bcfe3f /setup.py | |
parent | aaa216c6e0a3c1fd18fccd07ccd4c13230c9f87a (diff) | |
download | paste-git-e9827316dfb827a8005dbfc9b370edd7d330773e.tar.gz |
Remove pytest-runner integration (#47)
`pytest-runner` describes itself as deprecated in its own package
description, referring to
https://github.com/pypa/setuptools/issues/1684. Using it in
`setup_requires` means that any other package that depends on Paste has
to install `pytest-runner` too, which is fairly heavyweight and
unnecessary. (I ran into this when trying to update Launchpad to a less
ancient version of Paste.)
This does mean that `python setup.py test` no longer works, but,
according to the setuptools issue above, that's deprecated anyway.
Paste already has `tox` configuration that works well.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 0 insertions, 2 deletions
@@ -52,9 +52,7 @@ setup(name="Paste", exclude_directories=finddata.standard_exclude_directories + ('tests',)), namespace_packages=['paste'], zip_safe=False, - setup_requires=['pytest-runner'], install_requires=['six>=1.4.0'], - tests_require=['pytest'], extras_require={ 'subprocess': [], 'hotshot': [], |