summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.cfg1
-rw-r--r--setup.py4
2 files changed, 3 insertions, 2 deletions
diff --git a/setup.cfg b/setup.cfg
index 7300c5b..20def47 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -5,6 +5,7 @@ tag_svn_revision = 0
[aliases]
distribute = register sdist bdist_egg upload pudge publish
+test = pytest
[bdist_wheel]
universal=1
diff --git a/setup.py b/setup.py
index 8f10069..9bd65d7 100644
--- a/setup.py
+++ b/setup.py
@@ -52,9 +52,9 @@ setup(name="Paste",
exclude_directories=finddata.standard_exclude_directories + ('tests',)),
namespace_packages=['paste'],
zip_safe=False,
- test_suite='nose.collector',
+ setup_requires=['pytest-runner'],
install_requires=['six>=1.4.0'],
- tests_require=['nose>=0.11'],
+ tests_require=['pytest'],
extras_require={
'subprocess': [],
'hotshot': [],