summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 21 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b7e92b1..88ce93b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,27 @@
+# Procedure to release a new version:
+#
+# - run tests: run tox
+# - update version in setup.py (__version__)
+# - update tag_build in setup.cfg
+# - update changelog: docs/news.txt
+# - modify setup.py: set RELEASE to True
+# - check that "python setup.py sdist" contains all files tracked by
+# the SCM (Mercurial): update MANIFEST.in if needed
+#
+# - hg ci
+# - hg tag VERSION
+# - hg push
+# - python2 setup.py register sdist bdist_wheel upload
+# - python3 setup.py bdist_wheel upload
+#
+# - increment version in setup.py (__version__)
+# - hg ci && hg push
+
# If true, then the svn revision won't be used to calculate the
# revision (set to True for real releases)
-RELEASE = False
+RELEASE = True
-__version__ = '1.7.5.1'
+__version__ = '2.0'
from setuptools import setup, find_packages
import sys, os