summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9ff4382..2197f98 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,19 @@
# Procedure to release a new version:
-# - run tests
+#
+# - run tests: run tox
# - update version in setup.py (__version__)
# - update changelog: docs/news.txt
# - modify setup.py: set RELEASE to True
+# - check that "python setup.py sdist" contains all files tracked by
+# the SCM (Mercurial): update MANIFEST.in if needed
+#
+# - hg ci
+# - hg tag VERSION
+# - hg push
+# - python setup.py register sdist bdist_wheel upload
+#
+# - increment version in setup.py (__version__)
+# - hg ci && hg push
# If true, then the svn revision won't be used to calculate the
# revision (set to True for real releases)