summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2018-11-23 04:36:14 -0800
committerSteve Piercy <web@stevepiercy.com>2018-11-23 04:36:14 -0800
commit98cabc41ecf67c67123af7e08d4abc96839ae5d1 (patch)
tree035d0f465e1c958c7d99778cd9632d4f4b584e6f
parent5c6f580d9a9eb29ea7316e83cb083d6f9500f37b (diff)
downloadpastedeploy-git-98cabc41ecf67c67123af7e08d4abc96839ae5d1.tar.gz
Update URLs in README and setup.py
- See #2 and #4
-rw-r--r--README.rst12
-rw-r--r--setup.py9
2 files changed, 13 insertions, 8 deletions
diff --git a/README.rst b/README.rst
index 291a026..0524978 100644
--- a/README.rst
+++ b/README.rst
@@ -1,11 +1,11 @@
This tool provides code to load WSGI applications and servers from
-URIs; these URIs can refer to Python Eggs for INI-style configuration
-files. `Paste Script <http://pythonpaste.org/script>`_ provides
+URIs. These URIs can refer to Python eggs for INI-style configuration
+files. `Paste Script <https://github.com/Pylons/pastescript>`_ provides
commands to serve applications based on this configuration file.
-The latest version is available in a `Mercurial repository
-<http://bitbucket.org/ianb/pastedeploy>`_ (or a `tarball
-<http://bitbucket.org/ianb/pastedeploy/get/tip.gz#egg=PasteDeploy-dev>`_).
+The latest version is available on `GitHub
+<https://github.com/Pylons/pastedeploy/>`_ (or download a wheel or tarball from
+`PyPI <https://pypi.org/project/PasteDeploy/#files>`_).
For the latest changes see the `news file
-<http://pythonpaste.org/deploy/news.html>`_. \ No newline at end of file
+<https://docs.pylonsproject.org/projects/pastedeploy/en/latest/news.html>`_.
diff --git a/setup.py b/setup.py
index b5d6be4..5a8d019 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import os
from setuptools import setup, find_packages
here = os.path.dirname(__file__)
-readme_path = os.path.join(here, 'README.rst.rst')
+readme_path = os.path.join(here, "README.rst")
readme = open(readme_path).read()
@@ -36,7 +36,12 @@ setup(
author_email='ianb@colorstudy.com',
maintainer='Alex Gronholm',
maintainer_email='alex.gronholm@nextday.fi',
- url='http://pythonpaste.org/deploy/',
+ url="https://pylonsproject.org/",
+ project_urls={
+ "Documentation": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/",
+ "Changelog": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/news.html",
+ "Issue Tracker": "https://github.com/Pylons/pastedeploy/issues",
+ },
license='MIT',
namespace_packages=['paste'],
packages=find_packages(exclude=['tests']),