summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2018-11-26 21:50:17 +0900
committerChris Dent <chris.dent@gmail.com>2018-11-26 12:50:17 +0000
commita207e5c8976e4f7bcf0e80ba4d94ccbf7a7f2670 (patch)
treea5469bfef3d3a81c924b30a77135f23763cf7b61
parenteacb37de3de476c191a4471770ba08ff2939b241 (diff)
downloadpastedeploy-git-a207e5c8976e4f7bcf0e80ba4d94ccbf7a7f2670.tar.gz
Update URLs in setup.py and README (#10)
* Rename to README.rst for better rendering on GitHub * Update URLs in README and setup.py - See #2 and #4 * Add docs_extra to setup.py * Use pylons-sphinx-themes for pylons * Fix broken link to get initial html docs built * Move license.txt to root of repo in hopes that GitHub will find it * Remove obsolete links from navigation * Remove license from docs * Update link to pastescript in README.rst
-rw-r--r--README11
-rw-r--r--README.rst11
-rw-r--r--docs/_static/paste.css15
-rw-r--r--docs/_templates/layout.html20
-rw-r--r--docs/conf.py23
-rw-r--r--docs/index.txt5
-rw-r--r--license.txt (renamed from docs/license.txt)0
-rw-r--r--setup.py14
8 files changed, 43 insertions, 56 deletions
diff --git a/README b/README
deleted file mode 100644
index 291a026..0000000
--- a/README
+++ /dev/null
@@ -1,11 +0,0 @@
-This tool provides code to load WSGI applications and servers from
-URIs; these URIs can refer to Python Eggs for INI-style configuration
-files. `Paste Script <http://pythonpaste.org/script>`_ provides
-commands to serve applications based on this configuration file.
-
-The latest version is available in a `Mercurial repository
-<http://bitbucket.org/ianb/pastedeploy>`_ (or a `tarball
-<http://bitbucket.org/ianb/pastedeploy/get/tip.gz#egg=PasteDeploy-dev>`_).
-
-For the latest changes see the `news file
-<http://pythonpaste.org/deploy/news.html>`_. \ No newline at end of file
diff --git a/README.rst b/README.rst
new file mode 100644
index 0000000..7e4dcac
--- /dev/null
+++ b/README.rst
@@ -0,0 +1,11 @@
+This tool provides code to load WSGI applications and servers from
+URIs. These URIs can refer to Python eggs for INI-style configuration
+files. `Paste Script <https://github.com/cdent/pastescript>`_ provides
+commands to serve applications based on this configuration file.
+
+The latest version is available on `GitHub
+<https://github.com/Pylons/pastedeploy/>`_ (or download a wheel or tarball from
+`PyPI <https://pypi.org/project/PasteDeploy/#files>`_).
+
+For the latest changes see the `news file
+<https://docs.pylonsproject.org/projects/pastedeploy/en/latest/news.html>`_.
diff --git a/docs/_static/paste.css b/docs/_static/paste.css
deleted file mode 100644
index 6705e5d..0000000
--- a/docs/_static/paste.css
+++ /dev/null
@@ -1,15 +0,0 @@
-a.invisible-link {
- color: #fff;
- text-decoration: none;
-}
-
-a.invisible-link:visited {
- color: #fff;
- text-decoration: none;
-}
-
-a.invisible:link {
- color: #fff;
- text-decoration: none;
-}
-
diff --git a/docs/_templates/layout.html b/docs/_templates/layout.html
deleted file mode 100644
index a6d2a97..0000000
--- a/docs/_templates/layout.html
+++ /dev/null
@@ -1,20 +0,0 @@
-{% extends "!layout.html" %}
-
-{% block extrahead %}
-{{ super() }}
-<link rel="stylesheet" type="text/css"
- href="{{ pathto('_static/paste.css') }}">
-{% endblock %}
-
-{% block sidebartoc %}
-<h3><a href="http://pythonpaste.org/" class="invisible-link">Python Paste</a></h3>
-
-<ul>
-<li><a href="http://trac.pythonpaste.org">Issue tracker</a></li>
-<li><a href="http://pythonpaste.org/">Paste core</a></li>
-<li><a href="http://pythonpaste.org/deploy/">Paste Deploy</a></li>
-<li><a href="http://pythonpaste.org/script/">Paste Script</a></li>
-</ul>
-
-{{ super() }}
-{% endblock %}
diff --git a/docs/conf.py b/docs/conf.py
index af16cab..17bdf1c 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -12,6 +12,7 @@
# serve to show the default value.
import sys
+import pylons_sphinx_themes
# If your extensions are in another directory, add it here.
#sys.path.append('some/directory')
@@ -71,10 +72,16 @@ pygments_style = 'sphinx'
# Options for HTML output
# -----------------------
+html_theme = 'pylons'
+html_theme_path = pylons_sphinx_themes.get_html_themes_path()
+html_theme_options = dict(
+ canonical_url='https://docs.pylonsproject.org/projects/pastedeploy/en/latest/'
+)
+
# The style sheet to use for HTML and HTML Help pages. A file of that name
# must exist either in Sphinx' static/ path, or in one of the custom paths
# given in html_static_path.
-html_style = 'default.css'
+# html_style = 'default.css'
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
@@ -85,15 +92,21 @@ html_static_path = ['_static']
# using the given strftime format.
html_last_updated_fmt = '%b %d, %Y'
-# If true, SmartyPants will be used to convert quotes and dashes to
-# typographically correct entities.
-#html_use_smartypants = True
+# Do not use smart quotes.
+smartquotes = False
# Content template for the index page.
#html_index = ''
# Custom sidebar templates, maps document names to template names.
-#html_sidebars = {}
+# Control display of sidebars
+html_sidebars = { '**': [
+ 'localtoc.html',
+ 'ethicalads.html',
+ 'relations.html',
+ 'sourcelink.html',
+ 'searchbox.html',
+] }
# Additional templates that should be rendered to pages, maps page names to
# template names.
diff --git a/docs/index.txt b/docs/index.txt
index c085d27..e6c4351 100644
--- a/docs/index.txt
+++ b/docs/index.txt
@@ -14,7 +14,6 @@ Documents:
modules/loadwsgi
modules/config
modules/converters
- license
.. comment:
The names used in sections should be more concrete, and it should
@@ -67,7 +66,7 @@ Installation
First make sure you have either
`setuptools <http://peak.telecommunity.com/DevCenter/setuptools>`_ or its
modern replacement
-`distribute <http://pypi.python.org/pypi/distribute>`_ installed.
+`distribute <https://pypi.org/project/distribute/>`_ installed.
For Python 3.x you need distribute as setuptools does not work on it.
Then you can install Paste Deployment using `pip
@@ -451,7 +450,7 @@ other with the attributes ``.local_conf`` and ``.global_conf``.
`Python Eggs <http://peak.telecommunity.com/DevCenter/PythonEggs>`_
are a distribution and installation format produced by `setuptools
<http://peak.telecommunity.com/DevCenter/setuptools>`_ and
-`distribute <http://packages.python.org/distribute/>`_ that adds metadata to a
+`distribute <https://pypi.org/project/distribute/>`_ that adds metadata to a
normal Python package (among other things).
You don't need to understand a whole lot about Eggs to use them. If
diff --git a/docs/license.txt b/license.txt
index c810dec..c810dec 100644
--- a/docs/license.txt
+++ b/license.txt
diff --git a/setup.py b/setup.py
index 2ac2606..b421563 100644
--- a/setup.py
+++ b/setup.py
@@ -3,9 +3,13 @@ import os
from setuptools import setup, find_packages
here = os.path.dirname(__file__)
-readme_path = os.path.join(here, 'README')
+readme_path = os.path.join(here, "README.rst")
readme = open(readme_path).read()
+docs_extras = [
+ 'Sphinx >= 1.7.5', # Read The Docs minimum version
+ 'pylons-sphinx-themes',
+]
setup(
name='PasteDeploy',
@@ -36,7 +40,12 @@ setup(
author_email='ianb@colorstudy.com',
maintainer='Alex Gronholm',
maintainer_email='alex.gronholm@nextday.fi',
- url='http://pythonpaste.org/deploy/',
+ url="https://pylonsproject.org/",
+ project_urls={
+ "Documentation": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/",
+ "Changelog": "https://docs.pylonsproject.org/projects/pastedeploy/en/latest/news.html",
+ "Issue Tracker": "https://github.com/Pylons/pastedeploy/issues",
+ },
license='MIT',
namespace_packages=['paste'],
packages=find_packages(exclude=['tests']),
@@ -47,6 +56,7 @@ setup(
extras_require={
'Config': [],
'Paste': ['Paste'],
+ 'docs': docs_extras,
},
entry_points="""
[paste.filter_app_factory]