summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Piercy <web@stevepiercy.com>2018-11-23 05:07:49 -0800
committerSteve Piercy <web@stevepiercy.com>2018-11-23 05:07:49 -0800
commitaca1082bfc23269858da93dba2f93d700f656a86 (patch)
tree02fe8da1d86accf5a655991f460c15d1aa4c634f
parent98cabc41ecf67c67123af7e08d4abc96839ae5d1 (diff)
downloadpastedeploy-git-aca1082bfc23269858da93dba2f93d700f656a86.tar.gz
Add docs_extra to setup.py
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5a8d019..cf47dad 100644
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,10 @@ here = os.path.dirname(__file__)
readme_path = os.path.join(here, "README.rst")
readme = open(readme_path).read()
+docs_extras = [
+ 'Sphinx >= 1.7.5', # Read The Docs minimum version
+ 'pylons-sphinx-themes',
+]
setup(
name='PasteDeploy',
@@ -52,6 +56,7 @@ setup(
extras_require={
'Config': [],
'Paste': ['Paste'],
+ 'docs': docs_extras,
},
entry_points="""
[paste.filter_app_factory]