summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChris Dent <chris.dent@gmail.com>2018-11-22 19:11:32 +0000
committerChris Dent <chris.dent@gmail.com>2018-11-22 19:11:32 +0000
commit3082f349f2fe110bb6d5400e9caebbc29abc8bfe (patch)
tree326b045df162b1d508ba8cde17c257228276da48 /tox.ini
parentff81a47051c40a3998b0844ee130ec67e01a0b4b (diff)
downloadpastedeploy-git-3082f349f2fe110bb6d5400e9caebbc29abc8bfe.tar.gz
Make 'python setup.py test' work
Packagers sometimes like to use 'python setup.py test'. This change adjusts setup.py and setup.cfg to allow this to work with pytest instead of nose. To make things work, the settings for coverage need to be moved into tox.ini. A SkipTest in test_config_middleware is changed to its pytest equivalent.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini2
1 files changed, 1 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 42469da..4f0d91c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,4 +9,4 @@ deps =
pytest
pytest-cov
commands =
- py.test {posargs}
+ py.test --cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing {posargs}