summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/ISSUE_TEMPLATE/bug_report.md31
-rw-r--r--.github/ISSUE_TEMPLATE/documentation.md29
-rw-r--r--.github/ISSUE_TEMPLATE/feature_request.md24
-rw-r--r--contributing.md26
-rw-r--r--docs/Makefile107
-rw-r--r--pytest.ini1
-rw-r--r--setup.cfg3
-rw-r--r--tests/test_config_middleware.py2
-rw-r--r--tox.ini3
9 files changed, 222 insertions, 4 deletions
diff --git a/.github/ISSUE_TEMPLATE/bug_report.md b/.github/ISSUE_TEMPLATE/bug_report.md
new file mode 100644
index 0000000..260df9a
--- /dev/null
+++ b/.github/ISSUE_TEMPLATE/bug_report.md
@@ -0,0 +1,31 @@
+---
+name: Bug Report
+about: Create a report to help us improve
+
+---
+
+## Get Support
+To get help or technical support, see [Get Support](https://pylonsproject.org/community-support.html).
+
+## Bug Report
+
+Please [search the issue tracker](https://github.com/Pylons/pastedeploy/issues) for similar issues before submitting a new issue.
+
+**Describe the bug**
+A clear and concise description of the bug.
+
+**To Reproduce**
+Steps to reproduce the behavior:
+1. Go to '...'
+2. Click on '....'
+3. Scroll down to '....'
+4. See error
+
+**Expected behavior**
+A clear and concise description of what you expected to happen.
+
+**Screenshots**
+If applicable, add screenshots to help explain the issue.
+
+**Additional context**
+Add any other context about the issue here.
diff --git a/.github/ISSUE_TEMPLATE/documentation.md b/.github/ISSUE_TEMPLATE/documentation.md
new file mode 100644
index 0000000..a67b517
--- /dev/null
+++ b/.github/ISSUE_TEMPLATE/documentation.md
@@ -0,0 +1,29 @@
+---
+name: Documentation Suggestion
+about: Create an issue to improve our documentation
+
+---
+
+## Get Support
+To get help or technical support, see [Get Support](https://pylonsproject.org/community-support.html).
+
+## Documentation Suggestion
+
+Please [search the issue tracker](https://github.com/Pylons/pastedeploy/issues) for similar issues before submitting a new issue.
+
+**Describe the issue**
+A clear and concise description of the issue.
+
+**Include references**
+1. Go to the URL '...'
+2. Click on '....'
+3. Scroll down to '....'
+
+**Describe the improvement**
+A clear and concise description of your suggestion.
+
+**Screenshots**
+If applicable, add screenshots to help explain the issue.
+
+**Additional context**
+Add any other context about the issue here.
diff --git a/.github/ISSUE_TEMPLATE/feature_request.md b/.github/ISSUE_TEMPLATE/feature_request.md
new file mode 100644
index 0000000..3955722
--- /dev/null
+++ b/.github/ISSUE_TEMPLATE/feature_request.md
@@ -0,0 +1,24 @@
+---
+name: Feature Request
+about: Suggest an idea for this project
+
+---
+
+## Get Support
+To get help or technical support, see [Get Support](https://pylonsproject.org/community-support.html).
+
+## Feature Request
+
+Please [search the issue tracker](https://github.com/Pylons/pastedeploy/issues) for similar issues before submitting a new issue.
+
+**Is your feature request related to an issue? Please describe.**
+A clear and concise description of the issue. Example: "I'm always frustrated when [...]".
+
+**Describe the solution you'd like**
+A clear and concise description of what you want to happen.
+
+**Describe alternatives you've considered**
+A clear and concise description of any alternative solutions or features you've considered.
+
+**Additional context**
+Add any other context or screenshots about the feature request here.
diff --git a/contributing.md b/contributing.md
new file mode 100644
index 0000000..4dca72d
--- /dev/null
+++ b/contributing.md
@@ -0,0 +1,26 @@
+# Contributing
+
+All projects under the Pylons Project, including this one, follow the guidelines established at [How to Contribute](https://pylonsproject.org/community-how-to-contribute.html), [Coding Style and Standards](https://pylonsproject.org/community-coding-style-standards.html), and [Pylons Project Documentation Style Guide](https://docs.pylonsproject.org/projects/pastedeploy/).
+
+You can contribute to this project in several ways.
+
+* [File an Issue on GitHub](https://github.com/Pylons/pastedeploy/issues)
+* Fork this project, create a new branch, commit your suggested change, and push to your fork on GitHub.
+ When ready, submit a pull request for consideration.
+ [GitHub Flow](https://guides.github.com/introduction/flow/index.html) describes the workflow process and why it's a good practice.
+* Join the [IRC channel #pyramid on irc.freenode.net](https://webchat.freenode.net/?channels=pyramid).
+
+
+## Running Tests and Building Docs
+
+Run `tox` from within your checkout. This will run the tests across all supported systems and attempt to build the docs.
+
+To run the tests for Python 3.7 only:
+
+ $ tox -e py37
+
+To build the docs:
+
+ $ tox -e docs
+
+See the `tox.ini` file for details.
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000..91f36ae
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,107 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS = -W
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help clean html text web pickle htmlhelp latex latexpdf xelatexpdf changes linkcheck epub doctest
+
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " text to make text files"
+ @echo " pickle to make pickle files (usable by e.g. sphinx-web)"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " xelatexpdf to make LaTeX files and run them through xelatex"
+ @echo " changes to make an overview over all changed/added/deprecated items"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " epub to make an epub"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+clean:
+ -rm -rf $(BUILDDIR)/*
+
+xelatexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through xelatex..."
+ $(MAKE) PDFLATEX=xelatex -C $(BUILDDIR)/latex all-pdf
+ @echo "xelatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+html:
+ mkdir -p $(BUILDDIR)/html $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+text:
+ mkdir -p $(BUILDDIR)/text $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/text."
+
+pickle:
+ mkdir -p $(BUILDDIR)/pickle $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files or run"
+ @echo " sphinx-web $(BUILDDIR)/pickle"
+ @echo "to start the sphinx-web server."
+
+web: pickle
+
+htmlhelp:
+ mkdir -p $(BUILDDIR)/htmlhelp $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+latex:
+ mkdir -p $(BUILDDIR)/latex $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ cp _static/*.png $(BUILDDIR)/latex
+ ./convert_images.sh
+ cp _static/latex-warning.png $(BUILDDIR)/latex
+ cp _static/latex-note.png $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make xelatexpdf' to build a PDF file from them."
+
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF file is in $(BUILDDIR)/latex."
+
+changes:
+ mkdir -p $(BUILDDIR)/changes $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+linkcheck:
+ mkdir -p $(BUILDDIR)/linkcheck $(BUILDDIR)/doctrees
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
diff --git a/pytest.ini b/pytest.ini
index 69d62a0..5ee6477 100644
--- a/pytest.ini
+++ b/pytest.ini
@@ -1,3 +1,2 @@
[pytest]
-addopts = --cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing
testpaths = tests
diff --git a/setup.cfg b/setup.cfg
index f15c017..3c00092 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,2 +1,5 @@
[wheel]
universal = true
+
+[aliases]
+test = pytest
diff --git a/tests/test_config_middleware.py b/tests/test_config_middleware.py
index 56c3d04..52ba7d1 100644
--- a/tests/test_config_middleware.py
+++ b/tests/test_config_middleware.py
@@ -20,7 +20,7 @@ def test_error():
try:
from paste.fixture import TestApp
except ImportError:
- raise SkipTest
+ raise pytest.skip('unable to import TestApp')
wrapped = ConfigMiddleware(app_with_exception, {'test': 1})
test_app = TestApp(wrapped)
diff --git a/tox.ini b/tox.ini
index 55e85c9..7819491 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,14 +3,13 @@ envlist = py27, py34, py35, py36, py37, pypy, pypy3,
docs
[testenv]
-usedevelop = True
deps =
# Paste works on Python 3 since Paste 2.0
Paste
pytest
pytest-cov
commands =
- py.test {posargs}
+ py.test --cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing {posargs}
[testenv:docs]
# pin to 3.5 to match what RTD uses