summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini25
1 files changed, 22 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index 20fe9c4..d3b4d84 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,10 +1,29 @@
[tox]
-envlist = py26, py27, py33, py34, py35, pypy
+envlist = py26, py27, py33, py34, py35, pypy, cover, cover3
[testenv]
deps =
- nose
# Paste works on Python 3 since Paste 2.0
Paste
-commands = {envpython} setup.py test
+ pytest
+ pytest-cov
+commands =
+ py.test {posargs:tests/}
+[testenv:cover]
+basepython = python2.7
+usedevelop = True
+deps =
+ {[testenv]deps}
+ pytest-cov
+commands =
+ py.test {posargs:--cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing tests/}
+
+[testenv:cover3]
+basepython = python3.5
+usedevelop = True
+deps =
+ {[testenv]deps}
+ pytest-cov
+commands =
+ py.test {posargs:--cov=paste/deploy --cov-report=xml --cov-report=html --cov-report=term-missing tests/}