summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/conf.py2
-rw-r--r--docs/news.txt5
-rw-r--r--paste/deploy/util.py3
-rw-r--r--setup.py2
4 files changed, 8 insertions, 4 deletions
diff --git a/docs/conf.py b/docs/conf.py
index 8958fdf..af16cab 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -42,7 +42,7 @@ copyright = '2011, Ian Bicking and contributors'
# The short X.Y version.
version = '1.5'
# The full version, including alpha/beta/rc tags.
-release = '1.5.1'
+release = '1.5.2'
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
diff --git a/docs/news.txt b/docs/news.txt
index 854b5ad..bc1e987 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -1,6 +1,11 @@
Paste Deployment News
=====================
+1.5.2
+-----
+
+* Fixed Python 3 issue in paste.deploy.util.fix_type_error()
+
1.5.1
-----
diff --git a/paste/deploy/util.py b/paste/deploy/util.py
index 02d3fa2..b6f766a 100644
--- a/paste/deploy/util.py
+++ b/paste/deploy/util.py
@@ -32,8 +32,7 @@ def fix_type_error(exc_info, callable, varargs, kwargs):
if kwargs and args:
args += ', '
if kwargs:
- kwargs = kwargs.items()
- kwargs.sort()
+ kwargs = sorted(kwargs.items())
args += ', '.join(['%s=...' % n for n, v in kwargs])
gotspec = '(%s)' % args
msg = '%s; got %s, wanted %s' % (exc_info[1], gotspec, argspec)
diff --git a/setup.py b/setup.py
index b054254..79f9d70 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ readme = open(readme_path).read()
setup(
name='PasteDeploy',
- version='1.5.1',
+ version='1.5.2',
description='Load, configure, and compose WSGI applications and servers',
long_description=readme,
classifiers=[