summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 13 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 1959175..d3127a7 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,9 @@
from setuptools import setup, find_packages
-version = '1.3.4'
-
-import os
-
-here = os.path.dirname(os.path.abspath(__file__))
-finddata_py = os.path.join(here, 'tests', 'finddata.py')
-execfile(finddata_py)
setup(
name="PasteDeploy",
- version=version,
+ version='1.5.0dev',
description="Load, configure, and compose WSGI applications and servers",
long_description="""\
This tool provides code to load WSGI applications and servers from
@@ -30,22 +23,29 @@ For the latest changes see the `news file
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
+ "Programming Language :: Python :: 2.5",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
"Topic :: Internet :: WWW/HTTP",
"Topic :: Internet :: WWW/HTTP :: Dynamic Content",
- "Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Internet :: WWW/HTTP :: WSGI",
"Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware",
+ "Topic :: Software Development :: Libraries :: Python Modules",
"Framework :: Paste",
],
keywords='web wsgi application server',
author="Ian Bicking",
author_email="ianb@colorstudy.com",
+ maintainer="Alex Gronholm",
+ maintainer_email="alex.gronholm@nextday.fi",
url="http://pythonpaste.org/deploy/",
license='MIT',
namespace_packages=['paste'],
- packages=find_packages(exclude='tests'),
- package_data=find_package_data(
- exclude_directories=standard_exclude_directories + ('tests',)),
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
zip_safe=False,
test_suite='nose.collector',
tests_require=['nose>=0.11'],
@@ -70,4 +70,4 @@ For the latest changes see the `news file
paste.server_factory = paste.deploy.epdesc:ServerFactoryDescription
paste.server_runner = paste.deploy.epdesc:ServerRunnerDescription
""",
- )
+)