summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormarkmcclain <mark.mcclain@dreamhost.com>2013-04-24 19:24:27 -0700
committermarkmcclain <mark.mcclain@dreamhost.com>2013-04-24 19:24:27 -0700
commit2daac52e1bb070a06f725e7f2b833136bbb0ba6a (patch)
treec4f6623263f1ffb069748067af003715432c0b33
parentacdca0b861e204b488e69129224f305d4cccd89c (diff)
parent475bade620ab55e7711336c83341f833f9a6af3d (diff)
downloadpecan-2daac52e1bb070a06f725e7f2b833136bbb0ba6a.tar.gz
Merge pull request #210 from ryanpetrello/next
Rearrange quickstart verbiage so users don't miss a necessary step.
-rw-r--r--docs/source/quick_start.rst14
1 files changed, 6 insertions, 8 deletions
diff --git a/docs/source/quick_start.rst b/docs/source/quick_start.rst
index 8879a05..f0a52ed 100644
--- a/docs/source/quick_start.rst
+++ b/docs/source/quick_start.rst
@@ -22,13 +22,17 @@ your shell, type::
This example uses *test_project* as your project name, but you can replace
it with any valid Python package name you like.
-Go ahead and change into your newly created project directory::
+Go ahead and change into your newly created project directory. You'll want to
+deploy it in "development mode", such that it’s available on ``sys.path``, yet
+can still be edited directly from its source distribution::
$ cd test_project
- $ ls
+ $ python setup.py develop
This is how the layout of your new project should look::
+ $ ls
+
├── MANIFEST.in
├── config.py
├── public
@@ -92,12 +96,6 @@ You may notice that **model/__init__.py** is mostly empty. If your project
will interact with a database, this if where you should add code to parse
bindings from your configuration file and define tables and ORM definitions.
-Now that you've created your first Pecan application, you'll want to deploy it
-in "development mode", such that it’s available on ``sys.path``, yet can still
-be edited directly from its source distribution::
-
- $ python setup.py develop
-
.. _running_application:
Running the Application