summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-04-25 12:15:21 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-04-25 12:15:21 -0400
commit98f3c566ee3eb7f9d3b31e9e153dc8cbf3e22dc4 (patch)
tree376d117037529f34c22ec76799fd847ebcd53812
parentb294752202a7034a32dabc14c6497a80d9ee145a (diff)
downloadpecan-98f3c566ee3eb7f9d3b31e9e153dc8cbf3e22dc4.tar.gz
Version increment.
-rw-r--r--docs/source/changes.rst11
-rw-r--r--docs/source/conf.py4
-rw-r--r--setup.py2
3 files changed, 14 insertions, 3 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 9a6cefe..26453d4 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,14 @@
+0.2.3
+=====
+* Add a variety of optimizations to ``pecan.core`` that improve request
+ handling time by approximately 30% for simple object dispatch routing.
+* Store exceptions raised by ``abort`` in the WSGI environ so they can be
+ accessed later in the request handling (e.g., by other middleware or pecan
+ hooks).
+* Make TransactionHook more robust so that it isn't as susceptible to failure
+ when exceptions occur in *other* pecan hooks within a request.
+* Rearrange quickstart verbiage so users don't miss a necessary step.
+
0.2.2
=====
* Unobfuscate syntax highlighting JavaScript for debian packaging.
diff --git a/docs/source/conf.py b/docs/source/conf.py
index 163224d..ff740e9 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -49,9 +49,9 @@ copyright = u'2010, Jonathan LaCour'
# built documents.
#
# The short X.Y version.
-version = '0.2.2'
+version = '0.2.3'
# The full version, including alpha/beta/rc tags.
-release = '0.2.2'
+release = '0.2.3'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 10b3886..758774c 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@ import sys
from setuptools import setup, find_packages
from setuptools.command.test import test as TestCommand
-version = '0.2.2'
+version = '0.2.3'
#
# determine requirements