summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-08-13 15:33:29 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-08-13 15:40:20 -0400
commit106ba3afbaa321f080ce57e9a7a303ca6c303eed (patch)
tree5534118701c30b4e218760d90a0496003b80783b
parent6086f0f84ed9e2ab3c53f940e4233c94fa446314 (diff)
downloadpecan-106ba3afbaa321f080ce57e9a7a303ca6c303eed.tar.gz
Update docs and package metadata to reflect gerrit review process.
Change-Id: I5cc6cfa31bb899ea32f6d9cb37d86dc0275d09fc
-rw-r--r--.travis.yml19
-rw-r--r--CONTRIBUTING.rst39
-rw-r--r--README.rst7
-rw-r--r--docs/source/installation.rst6
-rw-r--r--setup.py2
5 files changed, 36 insertions, 37 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 61757d2..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,19 +0,0 @@
-language: python
-python:
- - "2.6"
- - "2.7"
- - "3.2"
- - "3.3"
-env:
- - PYTHONPATH='.'
-branches:
- only:
- - master
- - next
-install:
- - pip install gunicorn --use-mirrors
- - pip install -r requirements.txt --use-mirrors
- - pip install pep8 --use-mirrors
-before_script:
- - pep8 --repeat --show-source --ignore=E125 --statistics --exclude *compat*,resources.py, pecan setup.py
-script: python setup.py test
diff --git a/CONTRIBUTING.rst b/CONTRIBUTING.rst
index 0d0eece..733d3c8 100644
--- a/CONTRIBUTING.rst
+++ b/CONTRIBUTING.rst
@@ -1,12 +1,32 @@
Contributing to Pecan
---------------------
-To fix bugs or add features to Pecan, a GitHub account is required.
+Pecan uses the Gerrit code review system for bug fixes and feature additions.
-The general practice for contributing is to `fork Pecan
-<http://help.github.com/fork-a-repo/>`_ and make changes in the ``next``
-branch. When you're finished, `send a pull request
-<http://help.github.com/send-pull-requests/>`_ and the developers will review
-your patch.
+**Pull requests submitted through GitHub will be ignored.**
+
+To contribute:
+
+ * Visit `review.openstack.org <http://review.openstack.org>`_ and click the
+ *Sign In* link at the top-right corner of the page. Log in with your
+ Launchpad ID (or register a new account).
+ * ``$ git clone`` pecan locally and create a `topic branch
+ <http://git-scm.com/book/ch3-4.html#Topic-Branches>`_ to hold your work.
+ The general convention when working on bugs is to name the branch
+ ``bug/BUG-NUMBER`` (e.g., ``bug/1234567``). Otherwise, give it
+ a meaningful name because it will show up as the topic for your change in
+ Gerrit.
+ * Commit your work and submit a review (``$ git review``)
+
+::
+
+ $ git clone https://github.com/stackforge/pecan.git && cd pecan
+ $ git checkout -b bug/1234
+ $ pip install git-review && git review -s
+ # Make changes
+ $ pip install tox && tox
+ $ git add .
+ $ git commit -a
+ $ git review
All contributions must:
@@ -14,7 +34,10 @@ All contributions must:
* Include narrative and API documentation if new features are added.
* Be (generally) compliant with `PEP8
<http://www.python.org/dev/peps/pep-0008/>`_.
- * Not break the test or build. Before issuing a pull request, ``$ pip
+ * Not break the test or build. Before submitting a review, ``$ pip
install tox && tox`` from your source to ensure that all tests still pass
across multiple versions of Python.
- * Add your name to the (bottom of the) AUTHORS file.
+
+Bugs should be filed on Launchpad, not GitHub:
+
+https://bugs.launchpad.net/pecan
diff --git a/README.rst b/README.rst
index 8c5b7a3..2532466 100644
--- a/README.rst
+++ b/README.rst
@@ -4,15 +4,10 @@ Pecan
A WSGI object-dispatching web framework, designed to be lean and fast with few
dependencies.
-.. _travis: http://travis-ci.org/dreamhost/pecan
-.. |travis| image:: https://secure.travis-ci.org/dreamhost/pecan.png
-
.. image:: https://pypip.in/v/pecan/badge.png
:target: https://crate.io/packages/pecan/
:alt: Latest PyPI version
-|travis|_
-
Installing
----------
@@ -22,7 +17,7 @@ Installing
...or, for the latest (unstable) tip::
- $ git clone https://github.com/dreamhost/pecan.git -b next
+ $ git clone https://github.com/stackforge/pecan.git
$ cd pecan && python setup.py install
Running Tests
diff --git a/docs/source/installation.rst b/docs/source/installation.rst
index dd66a1f..eae40e8 100644
--- a/docs/source/installation.rst
+++ b/docs/source/installation.rst
@@ -32,7 +32,7 @@ Development (Unstable) Version
If you want to run the latest development version of Pecan you will
need to install git and clone the repo from GitHub::
- $ git clone https://github.com/dreamhost/pecan.git -b next
+ $ git clone https://github.com/stackforge/pecan.git
Assuming your virtual environment is still activated, call ``setup.py`` to
install the development version.::
@@ -41,9 +41,9 @@ install the development version.::
$ python setup.py develop
.. note::
- The ``next`` development branch is **very** volatile and is never
+ The ``master`` development branch is volatile and is generally not
recommended for production use.
Alternatively, you can also install from GitHub directly with ``pip``.::
- $ pip install -e git://github.com/dreamhost/pecan.git@next#egg=pecan
+ $ pip install -e git://github.com/stackforge/pecan.git#egg=pecan
diff --git a/setup.py b/setup.py
index 0914427..8cf6df3 100644
--- a/setup.py
+++ b/setup.py
@@ -92,7 +92,7 @@ setup(
keywords='web framework wsgi object-dispatch http',
author='Jonathan LaCour',
author_email='info@pecanpy.org',
- url='http://github.com/dreamhost/pecan',
+ url='http://github.com/stackforge/pecan',
license='BSD',
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,