summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2014-05-28 19:28:45 +0000
committerGerrit Code Review <review@openstack.org>2014-05-28 19:28:45 +0000
commit9bc09ea9c6d0cf311c508e6e0a4dce8df9855384 (patch)
tree947e526b863594ef14517648991700d04a108cf6
parentdc1f7fe5a6166cb8bf5b03382989cf3d2ec84d04 (diff)
parent18275cf3e1984d034de8c1aa6dfbc7b9f9771b01 (diff)
downloadpecan-9bc09ea9c6d0cf311c508e6e0a4dce8df9855384.tar.gz
Merge "Gate on stable/icehouse, and a few new projects that use pecan."
-rw-r--r--tox.ini26
1 files changed, 25 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index cbd59ab..0c69b9a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -141,7 +141,7 @@ commands = nosetests -v tests/pecantest
[testenv:ceilometer-stable]
basepython = python2.6
-deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/havana#egg=ceilometer
+deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/icehouse#egg=ceilometer
changedir = {envdir}/src/ceilometer
commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
@@ -155,6 +155,14 @@ commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py26
+[testenv:ironic-stable]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/ironic@stable/icehouse#egg=ironic
+changedir = {envdir}/src/ironic
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:ironic-tip]
basepython = python2.7
deps = -egit+http://git.openstack.org/cgit/openstack/ironic#egg=ironic
@@ -163,6 +171,22 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:barbican-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/stackforge/barbican#egg=barbican
+changedir = {envdir}/src/barbican
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/barbican/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
+[testenv:storyboard-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack-infra/storyboard#egg=storyboard
+changedir = {envdir}/src/storyboard
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py