summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2012-03-30 15:53:52 -0400
committerRyan Petrello <lists@ryanpetrello.com>2012-03-30 16:10:51 -0400
commit29d0f6944627bf96c963a62f5cc37781d987fabf (patch)
treed1242834893399a81e030d50172706be0452f5b2 /README.rst
parent7837ef731036c9b64bc9f27f1debaa19575f3069 (diff)
downloadpecan-29d0f6944627bf96c963a62f5cc37781d987fabf.tar.gz
README improvements.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst50
1 files changed, 50 insertions, 0 deletions
diff --git a/README.rst b/README.rst
index eee07a7..876212e 100644
--- a/README.rst
+++ b/README.rst
@@ -1,3 +1,6 @@
+Pecan
+=====
+
A WSGI object-dispatching web framework, designed to be lean and fast with few
dependencies.
@@ -5,3 +8,50 @@ dependencies.
.. |travis| image:: https://secure.travis-ci.org/dreamhost/pecan.png
|travis|_
+
+Installing
+----------
+::
+ $ pip install pecan
+
+...or, for the latest (unstable) tip::
+
+ $ git clone https://github.com/dreamhost/pecan.git -b next
+ $ cd pecan && python setup.py develop
+
+Running Tests
+-------------
+::
+ $ python setup.py test
+
+Viewing Documentation
+---------------------
+`Available Online <http://pecan.readthedocs.org>`_, or to build manually::
+
+ $ cd docs && make html
+ $ open docs/build/html/index.html
+
+...or::
+
+ $ cd docs && make man
+ $ man docs/build/man/pecan.1
+
+Contributing to Pecan
+---------------------
+To fix bugs or add features to Pecan, a GitHub account is required.
+
+The general practice for contributing is to `fork Pecan
+<http://help.github.com/fork-a-repo/>`_ and make changes in the ``next``
+branch. When you're finished, `send a pull request
+<http://help.github.com/send-pull-requests/>`_ and the developers will review
+your patch.
+
+All contributions must:
+
+ * Include accompanying tests.
+ * Include narrative and API documentation if new features are added.
+ * Be (generally) compliant with `PEP8
+ <http://www.python.org/dev/peps/pep-0008/>`_.
+ * Not break the test or build. Before issuing a pull request, ``$ pip
+ install tox && tox`` from your source to ensure that all tests still pass
+ across multiple versions of Python.