summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-08-29 15:57:48 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-08-29 16:00:57 -0400
commit4a85581cd937542d6f0cbcd7fbef2180575fd756 (patch)
treecb9b658c6e653d631e9b1ee01e4e005d816173b2 /docs
parenta5695984349aae023097d31612a87c08930406cb (diff)
downloadpecan-4a85581cd937542d6f0cbcd7fbef2180575fd756.tar.gz
Document and test the uwsgi plugin.
Change-Id: I97449c5238ac8c8a9dbc334e628c4f7a414ff896
Diffstat (limited to 'docs')
-rw-r--r--docs/source/deployment.rst13
1 files changed, 2 insertions, 11 deletions
diff --git a/docs/source/deployment.rst b/docs/source/deployment.rst
index 9cc1fec..96b1b3a 100644
--- a/docs/source/deployment.rst
+++ b/docs/source/deployment.rst
@@ -174,21 +174,12 @@ Running Pecan applications with uWSGI is a snap::
$ pip install uwsgi
$ pecan create simpleapp && cd simpleapp
$ python setup.py develop
-
-Next, let's create a new file in the project root::
-
- # wsgi.py
- from pecan.deploy import deploy
- application = deploy('config.py')
-
-and then run it with::
-
- $ uwsgi --http-socket 127.0.0.1:8000 -H /path/to/virtualenv -w wsgi
+ $ uwsgi --http-socket :8080 --venv /path/to/virtualenv --pecan config.py
or using a Unix socket (that nginx, for example, could be configured to
`proxy to <http://projects.unbit.it/uwsgi/wiki/RunOnNginx>`_)::
- $ uwsgi -s /tmp/uwsgi.sock -H ../path/to/virtualenv -w wsgi
+ $ uwsgi -s /tmp/uwsgi.sock --venv /path/to/virtualenv --pecan config.py
Gunicorn
++++++++