summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2013-09-01 13:20:13 +0000
committerGerrit Code Review <review@openstack.org>2013-09-01 13:20:13 +0000
commit09ea1274589d51104d89d2b325906aa0a36c181a (patch)
tree4cdb5c1178532ec78dd73cabeb90cb53cb4d93fe /docs
parent2feae26eda106642dd13799474c7e3f5a9f818fa (diff)
parent4a85581cd937542d6f0cbcd7fbef2180575fd756 (diff)
downloadpecan-09ea1274589d51104d89d2b325906aa0a36c181a.tar.gz
Merge "Document and test the uwsgi plugin."
Diffstat (limited to 'docs')
-rw-r--r--docs/source/deployment.rst13
1 files changed, 2 insertions, 11 deletions
diff --git a/docs/source/deployment.rst b/docs/source/deployment.rst
index 9cc1fec..96b1b3a 100644
--- a/docs/source/deployment.rst
+++ b/docs/source/deployment.rst
@@ -174,21 +174,12 @@ Running Pecan applications with uWSGI is a snap::
$ pip install uwsgi
$ pecan create simpleapp && cd simpleapp
$ python setup.py develop
-
-Next, let's create a new file in the project root::
-
- # wsgi.py
- from pecan.deploy import deploy
- application = deploy('config.py')
-
-and then run it with::
-
- $ uwsgi --http-socket 127.0.0.1:8000 -H /path/to/virtualenv -w wsgi
+ $ uwsgi --http-socket :8080 --venv /path/to/virtualenv --pecan config.py
or using a Unix socket (that nginx, for example, could be configured to
`proxy to <http://projects.unbit.it/uwsgi/wiki/RunOnNginx>`_)::
- $ uwsgi -s /tmp/uwsgi.sock -H ../path/to/virtualenv -w wsgi
+ $ uwsgi -s /tmp/uwsgi.sock --venv /path/to/virtualenv --pecan config.py
Gunicorn
++++++++