diff options
author | Jonathan LaCour <jonathan@cleverdevil.org> | 2010-10-01 17:26:12 -0400 |
---|---|---|
committer | Jonathan LaCour <jonathan@cleverdevil.org> | 2010-10-01 17:26:12 -0400 |
commit | 72c636ca4d3ef900810b3a97aa4125c8505572bc (patch) | |
tree | 937c598f130e3c598d62ad792ac50400035de283 /setup.py | |
parent | abc1278bafd803acf64e7f03547eeaa65289befa (diff) | |
download | pecan-72c636ca4d3ef900810b3a97aa4125c8505572bc.tar.gz |
Added a basic project template for Pecan projects. Use "paster create
--template=pecan-base" to use it.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 8 insertions, 2 deletions
@@ -3,6 +3,9 @@ import sys, os, py version = '0.1' +# +# integration with py.test for `python setup.py test` +# class PyTest(Command): user_options = [] def initialize_options(self): @@ -13,6 +16,7 @@ class PyTest(Command): import py py.cmdline.pytest(py.std.sys.argv[2:]) + setup( name = 'pecan', version = version, @@ -36,9 +40,11 @@ setup( "Mako >= 0.3", "py >= 1.3.4", "WebTest >= 1.2.2", - "Paste >= 1.7.5.1" + "Paste >= 1.7.5.1", + "PasteScript >= 1.7.3" ], entry_points = """ - # -*- Entry points: -*- + [paste.paster_create_template] + pecan-base = templates:NewProjectTemplate """, ) |