summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan LaCour <jonathan@cleverdevil.org>2011-09-02 16:26:12 -0400
committerJonathan LaCour <jonathan@cleverdevil.org>2011-09-02 16:26:12 -0400
commitf87e43769a8bd14a651395071a51d6e5a591593d (patch)
treedf90c523f2bb4cb4c13fcca02eeb89bfa00dfce6 /setup.py
parentf2bbbd8e56c308ff0eba7ca44b48cef046db0851 (diff)
downloadpecan-f87e43769a8bd14a651395071a51d6e5a591593d.tar.gz
Making the setup.py even better.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 15 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 2564de6..a76e54b 100644
--- a/setup.py
+++ b/setup.py
@@ -48,8 +48,21 @@ setup(
version = version,
description = "A WSGI object-dispatching web framework, designed to be lean and fast, with few dependancies.",
long_description = None,
- classifiers = [],
- keywords = '',
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: Microsoft :: Windows',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ 'Topic :: Software Development :: Libraries :: Application Frameworks'
+ ],
+ keywords = 'web framework wsgi object-dispatch http',
author = 'Jonathan LaCour',
author_email = 'jonathan@cleverdevil.org',
url = 'http://github.com/pecan/pecan',