summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJonathan LaCour <jonathan@cleverdevil.org>2010-09-30 10:11:21 -0400
committerJonathan LaCour <jonathan@cleverdevil.org>2010-09-30 10:11:21 -0400
commitccde2c07c88c26526384d2f7ed885add29756278 (patch)
treef1454830ab1f0e2940dadc5df015d580750d880f /setup.py
parent31c2d315659d987eb2399b5b80b16d26df552ce7 (diff)
downloadpecan-ccde2c07c88c26526384d2f7ed885add29756278.tar.gz
Some reorganization, more tests, improved handling of errors, and
support for prioritized hooks.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 14 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2759b72..c92a79f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,18 @@
-from setuptools import setup, find_packages
-import sys, os
+from setuptools import setup, Command, find_packages
+import sys, os, py
version = '0.1'
+class PyTest(Command):
+ user_options = []
+ def initialize_options(self):
+ pass
+ def finalize_options(self):
+ pass
+ def run(self):
+ import py
+ py.cmdline.pytest(py.std.sys.argv[2:])
+
setup(
name = 'pecan',
version = version,
@@ -17,6 +27,7 @@ setup(
packages = find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data = True,
zip_safe = True,
+ cmdclass = {'test': PyTest},
install_requires=[
"WebOb >= 0.9.8",
"simplegeneric >= 0.7",
@@ -30,4 +41,4 @@ setup(
entry_points = """
# -*- Entry points: -*-
""",
-)
+) \ No newline at end of file