summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-04-30 21:51:40 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-04-30 21:51:40 -0400
commit2ed2fe64c3a7e93b2385d1a698d1cc1503b780b3 (patch)
treea3ac00921f6923a0c323cc803eb98a818b12a77a /tox.ini
parent0eccb084fc52cbf72be2dfd1bf4bf6a2819dea4d (diff)
downloadpecan-2ed2fe64c3a7e93b2385d1a698d1cc1503b780b3.tar.gz
Add scaffold tests for Python 3.2/3.3.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini28
1 files changed, 27 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 71223a7..e121735 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py32,py33,scaffolds-26,scaffolds-27,pep8
+envlist = py26,py27,py32,py33,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-33,pep8
[testenv]
commands={envpython} setup.py test -v
@@ -26,6 +26,32 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-32]
+basepython = python3.2
+deps = pep8
+ gunicorn
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
+[testenv:scaffolds-33]
+basepython = python3.3
+deps = pep8
+ gunicorn
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source --exclude *compat*,resources.py pecan setup.py