summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-03-06 18:46:23 +0000
committerRyan Petrello <lists@ryanpetrello.com>2014-03-06 20:46:47 +0000
commitb046c1e965e2a37758c5092402a92b46217d58b4 (patch)
tree9852d38032471e1ca347d3911edfafbd23648883 /tox.ini
parent32712c50926ef27c58e1f16e14a4389d1a201f4b (diff)
downloadpecan-b046c1e965e2a37758c5092402a92b46217d58b4.tar.gz
Add a pecan scaffold for generating a simple REST API.
Change-Id: Iae346dc2d9a9cc52f3c8b4b546793c8d9670f56d Fixes bug 1248822
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini59
1 files changed, 58 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index efa65fb..cbd59ab 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py32,py33,py34,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-33,scaffolds-34,pep8
+envlist = py26,py27,py32,py33,py34,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-33,scaffolds-34,scaffolds-26-rest-api,scaffolds-27-rest-api,scaffolds-32-rest-api,scaffolds-33-rest-api,scaffolds-34-rest-api,pep8
[testenv]
commands={envpython} setup.py test -v
@@ -20,6 +20,17 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-26-rest-api]
+basepython = python2.6
+deps = {[testenv:scaffolds-base]deps}
+ unittest2
+changedir={envdir}/tmp
+commands=pecan create testing123 rest-api
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:scaffolds-27]
basepython = python2.7
deps = {[testenv:scaffolds-base]deps}
@@ -30,6 +41,16 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-27-rest-api]
+basepython = python2.7
+deps = {[testenv:scaffolds-base]deps}
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123 rest-api
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:scaffolds-32]
basepython = python3.2
deps = {[testenv:scaffolds-base]deps}
@@ -42,6 +63,18 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-32-rest-api]
+basepython = python3.2
+deps = {[testenv:scaffolds-base]deps}
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123 rest-api
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:scaffolds-33]
basepython = python3.3
deps = {[testenv:scaffolds-base]deps}
@@ -54,6 +87,18 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-33-rest-api]
+basepython = python3.3
+deps = {[testenv:scaffolds-base]deps}
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123 rest-api
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:scaffolds-34]
basepython = python3.4
deps = {[testenv:scaffolds-base]deps}
@@ -66,6 +111,18 @@ commands=pecan create testing123
pep8 --repeat --show-source testing123/setup.py testing123/testing123
{envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+[testenv:scaffolds-34-rest-api]
+basepython = python3.4
+deps = {[testenv:scaffolds-base]deps}
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123 rest-api
+ curl "http://python-distribute.org/distribute_setup.py" -O
+ {envpython} distribute_setup.py
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
[testenv:wsme-stable]
basepython = python2.7
deps = nose