summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-08-29 15:57:48 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-08-29 16:00:57 -0400
commit4a85581cd937542d6f0cbcd7fbef2180575fd756 (patch)
treecb9b658c6e653d631e9b1ee01e4e005d816173b2 /tox.ini
parenta5695984349aae023097d31612a87c08930406cb (diff)
downloadpecan-4a85581cd937542d6f0cbcd7fbef2180575fd756.tar.gz
Document and test the uwsgi plugin.
Change-Id: I97449c5238ac8c8a9dbc334e628c4f7a414ff896
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini16
1 files changed, 9 insertions, 7 deletions
diff --git a/tox.ini b/tox.ini
index 951b808..59106f4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,10 +4,14 @@ envlist = py26,py27,py32,py33,scaffolds-26,scaffolds-27,scaffolds-32,scaffolds-3
[testenv]
commands={envpython} setup.py test -v
-[testenv:scaffolds-26]
-basepython = python2.6
+[testenv:scaffolds-base]
deps = pep8
gunicorn
+ uwsgi
+
+[testenv:scaffolds-26]
+basepython = python2.6
+deps = {[testenv:scaffolds-base]deps}
unittest2
changedir={envdir}/tmp
commands=pecan create testing123
@@ -18,7 +22,7 @@ commands=pecan create testing123
[testenv:scaffolds-27]
basepython = python2.7
-deps = {[testenv:scaffolds-26]deps}
+deps = {[testenv:scaffolds-base]deps}
changedir={[testenv:scaffolds-26]changedir}
commands=pecan create testing123
{envpython} testing123/setup.py install
@@ -28,8 +32,7 @@ commands=pecan create testing123
[testenv:scaffolds-32]
basepython = python3.2
-deps = pep8
- gunicorn
+deps = {[testenv:scaffolds-base]deps}
changedir={[testenv:scaffolds-26]changedir}
commands=pecan create testing123
curl "http://python-distribute.org/distribute_setup.py" -O
@@ -41,8 +44,7 @@ commands=pecan create testing123
[testenv:scaffolds-33]
basepython = python3.3
-deps = pep8
- gunicorn
+deps = {[testenv:scaffolds-base]deps}
changedir={[testenv:scaffolds-26]changedir}
commands=pecan create testing123
curl "http://python-distribute.org/distribute_setup.py" -O