summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2013-03-12 15:45:37 -0400
committerRyan Petrello <lists@ryanpetrello.com>2013-03-13 14:02:16 -0400
commit7b736524f904b113fe8123f079af7c4d6f505814 (patch)
treeb9a1986a28ce0dba9f65810eff8fffcb092872bc /tox.ini
parent1bf1debce68d6196cad058b5a19d2c9a04233199 (diff)
downloadpecan-7b736524f904b113fe8123f079af7c4d6f505814.tar.gz
Extract the scaffold-building tests into tox.
A lot of code was being utilized to provide a *much* slower version of what tox already provides. This changes scaffold-building tests to run in tox across Python versions.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini26
1 files changed, 24 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 55e2996..3c83bc2 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,8 +1,30 @@
[tox]
-envlist = py26,py27,pep8
+envlist = py26,py27,scaffolds-26,scaffolds-27,pep8
[testenv]
-commands=python setup.py test --functional
+commands={envpython} setup.py test -v
+
+[testenv:scaffolds-26]
+basepython = python2.6
+deps = pep8
+ gunicorn
+ unittest2
+changedir={envdir}/tmp
+commands=pecan create testing123
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
+
+[testenv:scaffolds-27]
+basepython = python2.7
+deps = {[testenv:scaffolds-26]deps}
+changedir={[testenv:scaffolds-26]changedir}
+commands=pecan create testing123
+ {envpython} testing123/setup.py install
+ {envpython} testing123/setup.py test -q
+ pep8 --repeat --show-source testing123/setup.py testing123/testing123
+ {envpython} {toxinidir}/pecan/tests/scaffold_builder.py
[testenv:pep8]
deps = pep8