summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/source/commands.rst8
-rw-r--r--docs/source/configuration.rst4
-rw-r--r--docs/source/index.rst2
-rw-r--r--docs/source/quick_start.rst9
4 files changed, 10 insertions, 13 deletions
diff --git a/docs/source/commands.rst b/docs/source/commands.rst
index 25b9c73..f40839c 100644
--- a/docs/source/commands.rst
+++ b/docs/source/commands.rst
@@ -184,7 +184,7 @@ and usage output it provides::
$ pecan wget config.py /path/to/some/resource
Additionally, you'll notice that the first line of ``GetCommand``'s docstring
-(``Issues a (simulated) HTTP GET and returns the request body.``) is
+- ``Issues a (simulated) HTTP GET and returns the request body`` - is
automatically used to describe the ``wget`` command in the output for ``$ pecan
-h``. Following this convention allows you to easily integrate a summary for
your command into the Pecan command line tool.
@@ -192,7 +192,7 @@ your command into the Pecan command line tool.
Registering a Custom Command
++++++++++++++++++++++++++++
Now that you've written your custom command, you’ll need to tell your
-distribution’s ``setup.py`` about its existence and re-install. Within your
+distribution’s ``setup.py`` about its existence and reinstall. Within your
distribution’s ``setup.py`` file, you'll find a call to ``setuptools.setup()``,
e.g., ::
@@ -206,7 +206,7 @@ e.g., ::
)
Assuming it doesn't exist already, we'll add the ``entry_points`` argument
-to the ``setup()`` call, and define a Pecan command definition for your custom
+to the ``setup()`` call, and define a ``[pecan.command]`` definition for your custom
command::
@@ -223,7 +223,7 @@ command::
"""
)
-Once you've done this, re-install your project in development to register the
+Once you've done this, reinstall your project in development to register the
new entry point::
$ python setup.py develop
diff --git a/docs/source/configuration.rst b/docs/source/configuration.rst
index 94c4dc9..befefcc 100644
--- a/docs/source/configuration.rst
+++ b/docs/source/configuration.rst
@@ -1,7 +1,7 @@
.. _configuration:
-Configuration
-=============
+Configuring Pecan Applications
+==============================
Pecan is very easy to configure. As long as you follow certain conventions,
using, setting and dealing with configuration should be very intuitive.
diff --git a/docs/source/index.rst b/docs/source/index.rst
index f5eefe9..ead4853 100644
--- a/docs/source/index.rst
+++ b/docs/source/index.rst
@@ -33,7 +33,6 @@ Narrative Documentation
installation.rst
quick_start.rst
- commands.rst
routing.rst
templates.rst
rest.rst
@@ -41,6 +40,7 @@ Narrative Documentation
secure_controller.rst
jsonify.rst
hooks.rst
+ commands.rst
testing.rst
diff --git a/docs/source/quick_start.rst b/docs/source/quick_start.rst
index baf0577..8b6705e 100644
--- a/docs/source/quick_start.rst
+++ b/docs/source/quick_start.rst
@@ -16,14 +16,11 @@ Base Application Template
A basic template for getting started is included with Pecan. From
your shell, type::
- $ pecan create
-
-The above command will prompt you for a project name. This example uses
-*test_project*, but you can also provide an argument at the end of the
-example command above, like::
-
$ pecan create test_project
+This example uses *test_project* as your project name, but you can replace
+it with any valid Python package name you like.
+
Go ahead and change into your newly created project directory::
$ cd test_project