summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann C. Rocholl <johann@rocholl.net>2010-09-19 20:45:53 -0700
committerJohann C. Rocholl <johann@rocholl.net>2010-09-19 20:45:53 -0700
commit29968a6fa42ea2802118df92bd829344d910b8ae (patch)
treed888052195a69ec8b7f75722180112e11e304265
parent8d2d68790b6931833277cd671dfb8158962fac0c (diff)
downloadpep8-29968a6fa42ea2802118df92bd829344d910b8ae.tar.gz
Release 0.6.0.
-rw-r--r--CHANGES.txt2
-rw-r--r--README.rst17
-rw-r--r--TODO.txt6
-rw-r--r--setup.py2
4 files changed, 21 insertions, 6 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 5de9d3a..4934a46 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,7 +2,7 @@ Changelog
=========
-0.5.1 (unreleased)
+0.6.0 (2010-09-19)
------------------
* Test suite reorganized and enhanced in order to check more failures
diff --git a/README.rst b/README.rst
index 81fd9cf..e8ad376 100644
--- a/README.rst
+++ b/README.rst
@@ -22,14 +22,25 @@ Features
* Small: Just one Python file, requires only stdlib. You can use just
the pep8.py file for this purpose.
-* Easy_installable, of course!
-
+* Comes with a comprehensive test suite.
Installation
------------
-Just an ``easy_install pep8`` ought to do the trick.
+You can install, upgrade, uninstall pep8.py with these commands::
+
+ $ sudo pip install pep8
+ $ sudo pip install --upgrade pep8
+ $ sudo pip uninstall pep8
+
+Or if you don't have `pip`::
+
+ $ sudo easy_install pep8
+
+There's also a package for Debian/Ubuntu, but it's not always the
+latest version::
+ $ sudo apt-get install pep8
Example usage and output
------------------------
diff --git a/TODO.txt b/TODO.txt
index f4d9348..d2aaf86 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -1,4 +1,8 @@
TODO
====
-- ...
+- Should command line option --repeat be enabled by default?
+
+- Does command line option --ignore properly prevent status code 1?
+
+- Release version 1.0 after a brief stabilization period.
diff --git a/setup.py b/setup.py
index bfc7ee6..f9d25c4 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.5.1dev'
+version = '0.6.0'
long_description = '\n\n'.join([open('README.rst').read(),
open('CHANGES.txt').read(),
open('TODO.txt').read()])