summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Xicluna <florent.xicluna@gmail.com>2012-03-26 02:09:51 +0200
committerFlorent Xicluna <florent.xicluna@gmail.com>2012-03-26 02:09:51 +0200
commitcba8f177ed560d25cebad65e86850d9c96c95b78 (patch)
treecf74e81d4ddd522f2fa670bf048e06f28cc0bb7a
parentc7730e14159b0c171a08871db467073bc85e0442 (diff)
downloadpep8-cba8f177ed560d25cebad65e86850d9c96c95b78.tar.gz
Merge fixes for issues #34, #43 and #48.
-rw-r--r--CHANGES.txt16
-rwxr-xr-xpep8.py5
-rw-r--r--setup.py16
3 files changed, 31 insertions, 6 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 4934a46..035d403 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,22 @@ Changelog
=========
+0.6.2 UNRELEASED
+----------------
+
+* Add PyPI classifiers. (Issue #43)
+
+* Fix the ``--exclude``option. (Issue #48)
+
+* Fix W602, accept ``raise`` with 3 arguments. (Issue #34)
+
+
+0.6.1 (2010-10-03)
+------------------
+
+* Fix inconsistent version numbers. (Issue #21)
+
+
0.6.0 (2010-09-19)
------------------
diff --git a/pep8.py b/pep8.py
index 1d25e8c..059c85e 100755
--- a/pep8.py
+++ b/pep8.py
@@ -92,7 +92,7 @@ for space.
"""
-__version__ = '0.5.1dev'
+__version__ = '0.6.2dev'
import os
import sys
@@ -1041,8 +1041,7 @@ def input_dir(dirname, runner=None):
if options.verbose:
message('directory ' + root)
options.counters['directories'] += 1
- dirs.sort()
- for subdir in dirs:
+ for subdir in sorted(dirs):
if excluded(subdir):
dirs.remove(subdir)
files.sort()
diff --git a/setup.py b/setup.py
index f9d25c4..8d79d58 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.6.0'
+version = '0.6.1'
long_description = '\n\n'.join([open('README.rst').read(),
open('CHANGES.txt').read(),
open('TODO.txt').read()])
@@ -9,7 +9,6 @@ setup(name='pep8',
version=version,
description="Python style guide checker",
long_description=long_description,
- classifiers=[],
keywords='pep8',
author='Johann C. Rocholl',
author_email='johann@rocholl.net',
@@ -28,4 +27,15 @@ setup(name='pep8',
'pep8 = pep8:_main',
],
},
- )
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+)