summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorent Xicluna <florent.xicluna@gmail.com>2012-12-22 00:28:12 +0100
committerFlorent Xicluna <florent.xicluna@gmail.com>2012-12-22 00:28:12 +0100
commit6cd56b573108b39ea1751dd06dd56c0e8f10a7c7 (patch)
treed11b8635723f838ac02ec48e1a55c5da5d72fecc
parent272571d14c2c07cf3008ab59782c554a1344ee3f (diff)
downloadpep8-6cd56b573108b39ea1751dd06dd56c0e8f10a7c7.tar.gz
Add Sphinx documentation
-rw-r--r--README.rst37
-rw-r--r--docs/Makefile153
-rw-r--r--docs/api.rst90
-rw-r--r--docs/conf.py250
-rw-r--r--docs/developer.rst69
-rw-r--r--docs/index.rst52
-rw-r--r--docs/intro.rst109
-rw-r--r--docs/make.bat190
8 files changed, 913 insertions, 37 deletions
diff --git a/README.rst b/README.rst
index 49cc3b6..b044c26 100644
--- a/README.rst
+++ b/README.rst
@@ -7,11 +7,6 @@ conventions in `PEP 8`_.
.. _PEP 8: http://www.python.org/dev/peps/pep-0008/
-Mailing List
-------------
-http://groups.google.com/group/pep8
-
-
Features
--------
@@ -123,38 +118,6 @@ Quick help is available on the command line::
--config=path config file location (default: /home/user/.config/pep8)
-Calling `pep8` from Python
---------------------------
-
-You can also execute `pep8` tests from Python code. For example, this
-can be highly useful for automated testing of coding style conformance
-in your project::
-
- import unittest
- import pep8
-
-
- class TestCodeFormat(unittest.TestCase):
-
- def test_pep8_conformance(self):
- """Test that we conform to PEP8."""
- pep8style = pep8.StyleGuide(quiet=True)
- result = pep8style.check_files(['file1.py', 'file2.py'])
- self.assertEqual(result.total_errors, 0,
- "Found code style errors (and warnings).")
-
-If you are using `nosetests` for running tests, remove `quiet=True`
-since Nose suppresses stdout.
-
-There's also a shortcut for checking a single file::
-
- import pep8
-
- fchecker = pep8.Checker('testsuite/E27.py', show_source=True)
- file_errors = fchecker.check_all()
-
- print("Found %s errors (and warnings)" % file_errors)
-
Feedback
--------
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000..1952db4
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,153 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = _build
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+# the i18n builder cannot share the environment and doctrees with the others
+I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest gettext
+
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " texinfo to make Texinfo files"
+ @echo " info to make Texinfo files and run them through makeinfo"
+ @echo " gettext to make PO message catalogs"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+clean:
+ -rm -rf $(BUILDDIR)/*
+
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/pep8.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/pep8.qhc"
+
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/pep8"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/pep8"
+ @echo "# devhelp"
+
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+texinfo:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo
+ @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
+ @echo "Run \`make' in that directory to run these through makeinfo" \
+ "(use \`make info' here to do that automatically)."
+
+info:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo "Running Texinfo files through makeinfo..."
+ make -C $(BUILDDIR)/texinfo info
+ @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
+
+gettext:
+ $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
+ @echo
+ @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
+
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
diff --git a/docs/api.rst b/docs/api.rst
new file mode 100644
index 0000000..09bedb9
--- /dev/null
+++ b/docs/api.rst
@@ -0,0 +1,90 @@
+========
+pep8 API
+========
+
+.. module:: pep8
+
+The library provides classes which are usable by third party tools.
+
+.. contents::
+ :local:
+
+
+.. _main_classes:
+
+Checker Classes
+---------------
+
+The :class:`StyleGuide` class is used to configure a style guide checker
+instance to check multiple files.
+
+The :class:`Checker` class can be used to check is a single file.
+
+
+.. autoclass:: StyleGuide(*args, **kwargs)
+
+ .. automethod:: init_report(reporter=None)
+ .. automethod:: check_files(paths=None)
+ .. automethod:: input_file(filename, lines=None, expected=None, line_offset=0)
+ .. automethod:: input_dir(dirname)
+ .. automethod:: excluded(filename)
+ .. automethod:: ignore_code(code)
+ .. automethod:: get_checks(argument_name)
+
+.. autoclass:: Checker(filename=None, lines=None, options=None, report=None, **kwargs)
+
+ .. automethod:: readline
+ .. automethod:: readline_check_physical
+ .. automethod:: run_check(check, argument_names)
+ .. automethod:: check_physical(line)
+ .. automethod:: build_tokens_line
+ .. automethod:: check_logical
+ .. automethod:: generate_tokens
+ .. automethod:: check_all(expected=None, line_offset=1)
+
+
+.. _report_classes:
+
+Report Classes
+--------------
+
+.. autoclass:: BaseReport(options)
+
+ .. automethod:: start
+ .. automethod:: stop
+ .. automethod:: init_file(filename, lines, expected, line_offset)
+ .. automethod:: increment_logical_line
+ .. automethod:: error(line_number, offset, text, check)
+ .. automethod:: get_file_results
+ .. automethod:: get_count(prefix='')
+ .. automethod:: get_statistics(prefix='')
+ .. automethod:: print_statistics(prefix='')
+ .. automethod:: print_benchmark
+
+.. autoclass:: FileReport
+
+.. autoclass:: StandardReport
+
+.. autoclass:: DiffReport
+
+.. autoclass:: TestReport
+
+
+Utilities
+---------
+
+.. autofunction:: expand_indent(line)
+.. autofunction:: mute_string(text)
+.. autofunction:: read_config(options, args, arglist, parser)
+.. autofunction:: process_options(arglist=None, parse_argv=False, config_file=None)
+
+..
+ These ones are used internally, but they don't need advertising
+ .. autofunction:: readlines(filename)
+ .. autofunction:: isidentifier(word)
+ .. autofunction:: stdin_get_value()
+ .. autofunction:: parse_udiff(diff, patterns=None, parent='.')
+ .. autofunction:: filename_match(filename, patterns, default=True)
+ .. autofunction:: find_checks(argument_name)
+ .. autofunction:: init_tests(pep8style)
+ .. autofunction:: selftest(options)
diff --git a/docs/conf.py b/docs/conf.py
new file mode 100644
index 0000000..e02e226
--- /dev/null
+++ b/docs/conf.py
@@ -0,0 +1,250 @@
+# -*- coding: utf-8 -*-
+#
+# pep8 documentation build configuration file, created by
+# sphinx-quickstart on Tue Aug 21 09:47:49 2012.
+#
+# This file is execfile()d with the current directory set to its
+# containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+import sys
+import os
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+#sys.path.insert(0, os.path.abspath('.'))
+sys.path.insert(0, os.path.abspath('..'))
+
+# -- General configuration ----------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest',
+ 'sphinx.ext.coverage', 'sphinx.ext.viewcode']
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['_templates']
+
+# The suffix of source filenames.
+source_suffix = '.rst'
+
+# The encoding of source files.
+#source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = 'index'
+
+# General information about the project.
+project = u'pep8'
+copyright = u'2012, Florent Xicluna'
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+
+pep8_version = __import__('pep8').__version__.split('.')
+# The short X.Y version.
+version = '.'.join(pep8_version[:2])
+# The full version, including alpha/beta/rc tags.
+release = '.'.join(pep8_version)
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+#today = ''
+# Else, today_fmt is used as the format for a strftime call.
+#today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+exclude_patterns = ['_build']
+
+# The reST default role (used for this markup: `text`) to use for
+# all documents.
+#default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+#add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+#add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+#show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+# A list of ignored prefixes for module index sorting.
+#modindex_common_prefix = []
+
+
+# -- Options for HTML output --------------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+html_theme = 'default'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+#html_theme_path = []
+
+# The name for this set of Sphinx documents. If None, it defaults to
+# "<project> v<release> documentation".
+#html_title = None
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+#html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+#html_logo = None
+
+# The name of an image file (within the static path) to use as favicon of the
+# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+#html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
+# using the given strftime format.
+#html_last_updated_fmt = '%b %d, %Y'
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+#html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+#html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+#html_additional_pages = {}
+
+# If false, no module index is generated.
+#html_domain_indices = True
+
+# If false, no index is generated.
+#html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+#html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+#html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+#html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+#html_show_copyright = True
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+#html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+#html_file_suffix = None
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'pep8doc'
+
+
+# -- Options for LaTeX output -------------------------------------------------
+
+latex_elements = {
+ # The paper size ('letterpaper' or 'a4paper').
+ #'papersize': 'letterpaper',
+
+ # The font size ('10pt', '11pt' or '12pt').
+ #'pointsize': '10pt',
+
+ # Additional stuff for the LaTeX preamble.
+ #'preamble': '',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto/manual]).
+latex_documents = [
+ ('index', 'pep8.tex', u'pep8 documentation',
+ u'Florent Xicluna', 'manual'),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+#latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+#latex_use_parts = False
+
+# If true, show page references after internal links.
+#latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+#latex_show_urls = False
+
+# Documents to append as an appendix to all manuals.
+#latex_appendices = []
+
+# If false, no module index is generated.
+#latex_domain_indices = True
+
+
+# -- Options for manual page output -------------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ ('index', 'pep8', u'pep8 documentation',
+ [u'Florent Xicluna'], 1)
+]
+
+# If true, show URL addresses after external links.
+#man_show_urls = False
+
+
+# -- Options for Texinfo output -----------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ ('index', 'pep8', u'pep8 documentation',
+ u'Florent Xicluna', 'pep8', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+# Documents to append as an appendix to all manuals.
+#texinfo_appendices = []
+
+# If false, no module index is generated.
+#texinfo_domain_indices = True
+
+# How to display URL addresses: 'footnote', 'no', or 'inline'.
+#texinfo_show_urls = 'footnote'
diff --git a/docs/developer.rst b/docs/developer.rst
new file mode 100644
index 0000000..1ffe623
--- /dev/null
+++ b/docs/developer.rst
@@ -0,0 +1,69 @@
+.. currentmodule:: pep8
+
+=================
+Developer's notes
+=================
+
+
+Source code
+~~~~~~~~~~~
+
+The source code is currently available on github. Fork away!
+Then be sure to pass the tests::
+
+ $ python pep8.py --testsuite testsuite
+ $ python pep8.py --doctest
+ $ python pep8.py --verbose pep8.py
+
+* `Source code <https://github.com/jcrocholl/pep8>`_ and
+ `issue tracker <https://github.com/jcrocholl/pep8/issues>`_ on GitHub.
+* `Continuous tests <http://travis-ci.org/jcrocholl/pep8>`_ against Python
+ 2.5 through 3.2 and PyPy, on `Travis-CI platform
+ <http://about.travis-ci.org/>`_.
+
+
+Third-party integration
+~~~~~~~~~~~~~~~~~~~~~~~
+
+You can also execute `pep8` tests from Python code. For example, this
+can be highly useful for automated testing of coding style conformance
+in your project::
+
+ import unittest
+ import pep8
+
+
+ class TestCodeFormat(unittest.TestCase):
+
+ def test_pep8_conformance(self):
+ """Test that we conform to PEP8."""
+ pep8style = pep8.StyleGuide(quiet=True)
+ result = pep8style.check_files(['file1.py', 'file2.py'])
+ self.assertEqual(result.total_errors, 0,
+ "Found code style errors (and warnings).")
+
+If you are using `nosetests` for running tests, remove `quiet=True`
+since Nose suppresses stdout.
+
+There's also a shortcut for checking a single file::
+
+ import pep8
+
+ fchecker = pep8.Checker('testsuite/E27.py', show_source=True)
+ file_errors = fchecker.check_all()
+
+ print("Found %s errors (and warnings)" % file_errors)
+
+See also:
+
+* the `list of error codes
+ <https://github.com/jcrocholl/pep8/wiki/ErrorCodes>`_.
+* the `list of related tools
+ <https://github.com/jcrocholl/pep8/wiki/RelatedTools>`_.
+
+
+Changes
+~~~~~~~
+
+.. include:: ../CHANGES.txt
+ :start-line: 3
diff --git a/docs/index.rst b/docs/index.rst
new file mode 100644
index 0000000..5e13ecd
--- /dev/null
+++ b/docs/index.rst
@@ -0,0 +1,52 @@
+.. pep8 documentation master file
+
+pep8's documentation
+====================
+
+*Python style guide checker*
+
+pep8 is a tool to check your Python code against some of the style
+conventions in `PEP 8`_.
+
+.. _PEP 8: http://www.python.org/dev/peps/pep-0008/
+
+
+Features
+--------
+
+* Plugin architecture: Adding new checks is easy.
+
+* Parseable output: Jump to error location in your editor.
+
+* Small: Just one Python file, requires only stdlib. You can use just
+ the pep8.py file for this purpose.
+
+* Comes with a comprehensive test suite.
+
+
+Contents:
+
+.. toctree::
+ :maxdepth: 2
+
+ intro
+ API <api>
+ developer
+
+* Online documentation: http://pep8.readthedocs.org/
+* Source code and issue tracker: https://github.com/jcrocholl/pep8
+
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`search`
+
+
+Credits
+=======
+
+Created by Johann C. Rocholl.
+
+Maintained by Florent Xicluna.
diff --git a/docs/intro.rst b/docs/intro.rst
new file mode 100644
index 0000000..aec4810
--- /dev/null
+++ b/docs/intro.rst
@@ -0,0 +1,109 @@
+.. currentmodule:: pep8
+
+Introduction
+============
+
+pep8 is a tool to check your Python code against some of the style
+conventions in `PEP 8`_.
+
+.. _PEP 8: http://www.python.org/dev/peps/pep-0008/
+
+
+Installation
+------------
+
+You can install, upgrade, uninstall pep8.py with these commands::
+
+ $ pip install pep8
+ $ pip install --upgrade pep8
+ $ pip uninstall pep8
+
+There's also a package for Debian/Ubuntu, but it's not always the
+latest version::
+
+ $ sudo apt-get install pep8
+
+Example usage and output
+------------------------
+
+::
+
+ $ pep8 --first optparse.py
+ optparse.py:69:11: E401 multiple imports on one line
+ optparse.py:77:1: E302 expected 2 blank lines, found 1
+ optparse.py:88:5: E301 expected 1 blank line, found 0
+ optparse.py:222:34: W602 deprecated form of raising exception
+ optparse.py:347:31: E211 whitespace before '('
+ optparse.py:357:17: E201 whitespace after '{'
+ optparse.py:472:29: E221 multiple spaces before operator
+ optparse.py:544:21: W601 .has_key() is deprecated, use 'in'
+
+You can also make pep8.py show the source code for each error, and
+even the relevant text from PEP 8::
+
+ $ pep8 --show-source --show-pep8 testsuite/E40.py
+ testsuite/E40.py:2:10: E401 multiple imports on one line
+ import os, sys
+ ^
+ Imports should usually be on separate lines.
+
+ Okay: import os\nimport sys
+ E401: import sys, os
+
+
+Or you can display how often each error was found::
+
+ $ pep8 --statistics -qq Python-2.5/Lib
+ 232 E201 whitespace after '['
+ 599 E202 whitespace before ')'
+ 631 E203 whitespace before ','
+ 842 E211 whitespace before '('
+ 2531 E221 multiple spaces before operator
+ 4473 E301 expected 1 blank line, found 0
+ 4006 E302 expected 2 blank lines, found 1
+ 165 E303 too many blank lines (4)
+ 325 E401 multiple imports on one line
+ 3615 E501 line too long (82 characters)
+ 612 W601 .has_key() is deprecated, use 'in'
+ 1188 W602 deprecated form of raising exception
+
+Quick help is available on the command line::
+
+ $ pep8 -h
+ Usage: pep8 [options] input ...
+
+ Options:
+ --version show program's version number and exit
+ -h, --help show this help message and exit
+ -v, --verbose print status messages, or debug with -vv
+ -q, --quiet report only file names, or nothing with -qq
+ -r, --repeat (obsolete) show all occurrences of the same error
+ --first show first occurrence of each error
+ --exclude=patterns exclude files or directories which match these comma
+ separated patterns (default: .svn,CVS,.bzr,.hg,.git)
+ --filename=patterns when parsing directories, only check filenames matching
+ these comma separated patterns (default: *.py)
+ --select=errors select errors and warnings (e.g. E,W6)
+ --ignore=errors skip errors and warnings (e.g. E4,W)
+ --show-source show source code for each error
+ --show-pep8 show text of PEP 8 for each error (implies --first)
+ --statistics count errors and warnings
+ --count print total number of errors and warnings to standard
+ error and set exit code to 1 if total is not null
+ --max-line-length=n set maximum allowed line length (default: 79)
+ --format=format set the error format [default|pylint|<custom>]
+ --diff report only lines changed according to the unified diff
+ received on STDIN
+
+ Testing Options:
+ --testsuite=dir run regression tests from dir
+ --doctest run doctest on myself
+ --benchmark measure processing speed
+
+ Configuration:
+ The project options are read from the [pep8] section of the .pep8 file
+ located in any parent folder of the path(s) being processed. Allowed
+ options are: exclude, filename, select, ignore, max-line-length,
+ count, format, quiet, show-pep8, show-source, statistics, verbose.
+
+ --config=path config file location (default: /home/user/.config/pep8)
diff --git a/docs/make.bat b/docs/make.bat
new file mode 100644
index 0000000..efa0e94
--- /dev/null
+++ b/docs/make.bat
@@ -0,0 +1,190 @@
+@ECHO OFF
+
+REM Command file for Sphinx documentation
+
+if "%SPHINXBUILD%" == "" (
+ set SPHINXBUILD=sphinx-build
+)
+set BUILDDIR=_build
+set ALLSPHINXOPTS=-d %BUILDDIR%/doctrees %SPHINXOPTS% .
+set I18NSPHINXOPTS=%SPHINXOPTS% .
+if NOT "%PAPER%" == "" (
+ set ALLSPHINXOPTS=-D latex_paper_size=%PAPER% %ALLSPHINXOPTS%
+ set I18NSPHINXOPTS=-D latex_paper_size=%PAPER% %I18NSPHINXOPTS%
+)
+
+if "%1" == "" goto help
+
+if "%1" == "help" (
+ :help
+ echo.Please use `make ^<target^>` where ^<target^> is one of
+ echo. html to make standalone HTML files
+ echo. dirhtml to make HTML files named index.html in directories
+ echo. singlehtml to make a single large HTML file
+ echo. pickle to make pickle files
+ echo. json to make JSON files
+ echo. htmlhelp to make HTML files and a HTML help project
+ echo. qthelp to make HTML files and a qthelp project
+ echo. devhelp to make HTML files and a Devhelp project
+ echo. epub to make an epub
+ echo. latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter
+ echo. text to make text files
+ echo. man to make manual pages
+ echo. texinfo to make Texinfo files
+ echo. gettext to make PO message catalogs
+ echo. changes to make an overview over all changed/added/deprecated items
+ echo. linkcheck to check all external links for integrity
+ echo. doctest to run all doctests embedded in the documentation if enabled
+ goto end
+)
+
+if "%1" == "clean" (
+ for /d %%i in (%BUILDDIR%\*) do rmdir /q /s %%i
+ del /q /s %BUILDDIR%\*
+ goto end
+)
+
+if "%1" == "html" (
+ %SPHINXBUILD% -b html %ALLSPHINXOPTS% %BUILDDIR%/html
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/html.
+ goto end
+)
+
+if "%1" == "dirhtml" (
+ %SPHINXBUILD% -b dirhtml %ALLSPHINXOPTS% %BUILDDIR%/dirhtml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/dirhtml.
+ goto end
+)
+
+if "%1" == "singlehtml" (
+ %SPHINXBUILD% -b singlehtml %ALLSPHINXOPTS% %BUILDDIR%/singlehtml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/singlehtml.
+ goto end
+)
+
+if "%1" == "pickle" (
+ %SPHINXBUILD% -b pickle %ALLSPHINXOPTS% %BUILDDIR%/pickle
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can process the pickle files.
+ goto end
+)
+
+if "%1" == "json" (
+ %SPHINXBUILD% -b json %ALLSPHINXOPTS% %BUILDDIR%/json
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can process the JSON files.
+ goto end
+)
+
+if "%1" == "htmlhelp" (
+ %SPHINXBUILD% -b htmlhelp %ALLSPHINXOPTS% %BUILDDIR%/htmlhelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can run HTML Help Workshop with the ^
+.hhp project file in %BUILDDIR%/htmlhelp.
+ goto end
+)
+
+if "%1" == "qthelp" (
+ %SPHINXBUILD% -b qthelp %ALLSPHINXOPTS% %BUILDDIR%/qthelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can run "qcollectiongenerator" with the ^
+.qhcp project file in %BUILDDIR%/qthelp, like this:
+ echo.^> qcollectiongenerator %BUILDDIR%\qthelp\pep8.qhcp
+ echo.To view the help file:
+ echo.^> assistant -collectionFile %BUILDDIR%\qthelp\pep8.ghc
+ goto end
+)
+
+if "%1" == "devhelp" (
+ %SPHINXBUILD% -b devhelp %ALLSPHINXOPTS% %BUILDDIR%/devhelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished.
+ goto end
+)
+
+if "%1" == "epub" (
+ %SPHINXBUILD% -b epub %ALLSPHINXOPTS% %BUILDDIR%/epub
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The epub file is in %BUILDDIR%/epub.
+ goto end
+)
+
+if "%1" == "latex" (
+ %SPHINXBUILD% -b latex %ALLSPHINXOPTS% %BUILDDIR%/latex
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; the LaTeX files are in %BUILDDIR%/latex.
+ goto end
+)
+
+if "%1" == "text" (
+ %SPHINXBUILD% -b text %ALLSPHINXOPTS% %BUILDDIR%/text
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The text files are in %BUILDDIR%/text.
+ goto end
+)
+
+if "%1" == "man" (
+ %SPHINXBUILD% -b man %ALLSPHINXOPTS% %BUILDDIR%/man
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The manual pages are in %BUILDDIR%/man.
+ goto end
+)
+
+if "%1" == "texinfo" (
+ %SPHINXBUILD% -b texinfo %ALLSPHINXOPTS% %BUILDDIR%/texinfo
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The Texinfo files are in %BUILDDIR%/texinfo.
+ goto end
+)
+
+if "%1" == "gettext" (
+ %SPHINXBUILD% -b gettext %I18NSPHINXOPTS% %BUILDDIR%/locale
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The message catalogs are in %BUILDDIR%/locale.
+ goto end
+)
+
+if "%1" == "changes" (
+ %SPHINXBUILD% -b changes %ALLSPHINXOPTS% %BUILDDIR%/changes
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.The overview file is in %BUILDDIR%/changes.
+ goto end
+)
+
+if "%1" == "linkcheck" (
+ %SPHINXBUILD% -b linkcheck %ALLSPHINXOPTS% %BUILDDIR%/linkcheck
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Link check complete; look for any errors in the above output ^
+or in %BUILDDIR%/linkcheck/output.txt.
+ goto end
+)
+
+if "%1" == "doctest" (
+ %SPHINXBUILD% -b doctest %ALLSPHINXOPTS% %BUILDDIR%/doctest
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Testing of doctests in the sources finished, look at the ^
+results in %BUILDDIR%/doctest/output.txt.
+ goto end
+)
+
+:end