summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-09-15 11:14:21 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-15 11:44:01 -0700
commit64c2e300cd1aed0abc82e75ed1139cc989c0e1b9 (patch)
tree4e1323bbf4a8c1bdfab679c88763ca63c533df2b
parent566cdc0cb22e5530902e456d0b315403ebab980c (diff)
downloadpep8-64c2e300cd1aed0abc82e75ed1139cc989c0e1b9.tar.gz
Remove suggestion and documentation of using unmaintained nose
The nose project has ceased development. The last commit is from Mar 3, 2016. From their docs page: https://nose.readthedocs.io/ > Note to Users > > Nose has been in maintenance mode for the past several years and will > likely cease without a new person/team to take over maintainership. > New projects should consider using Nose2, py.test, or just plain > unittest/unittest2.
-rw-r--r--CONTRIBUTING.rst14
-rw-r--r--docs/advanced.rst3
-rw-r--r--testsuite/support.py4
3 files changed, 3 insertions, 18 deletions
diff --git a/CONTRIBUTING.rst b/CONTRIBUTING.rst
index 9f55859..f55c5e9 100644
--- a/CONTRIBUTING.rst
+++ b/CONTRIBUTING.rst
@@ -69,7 +69,6 @@ GitHub has an excellent `guide`_.
The current tests are written in 2 styles:
* standard xUnit based only on stdlib unittest
- (can be executed with nose)
* functional test using a custom framework and executed by the
pycodestyle itself when installed in dev mode.
@@ -77,19 +76,12 @@ The current tests are written in 2 styles:
Running unittest
~~~~~~~~~~~~~~~~
-While the tests are writted using stdlib `unittest` module, the existing
-test include unit, integration and functional tests.
+The tests are writted using stdlib `unittest` module, the existing test
+include unit, integration and functional tests.
-There are a couple of ways to run the tests::
+To run the tests::
$ python setup.py test
- $ # Use nose to run specific test
- $ nosetests \
- > testsuite.test_blank_lines:TestBlankLinesDefault.test_initial_no_blank
- $ # Use nose to run a subset and check coverage, and check the resulting
- $ $ cover/pycodestyle_py.html in your browser
- $ nosetests --with-coverage --cover-html -s testsuite.test_blank_lines
-
Running functional
~~~~~~~~~~~~~~~~~~
diff --git a/docs/advanced.rst b/docs/advanced.rst
index fd3cf3e..89700d5 100644
--- a/docs/advanced.rst
+++ b/docs/advanced.rst
@@ -25,9 +25,6 @@ in your project::
self.assertEqual(result.total_errors, 0,
"Found code style errors (and warnings).")
-If you are using ``nosetests`` for running tests, remove ``quiet=True``
-since Nose suppresses stdout.
-
There's also a shortcut for checking a single file::
import pycodestyle
diff --git a/testsuite/support.py b/testsuite/support.py
index bcca4e4..cbe2f46 100644
--- a/testsuite/support.py
+++ b/testsuite/support.py
@@ -215,7 +215,3 @@ def run_tests(style):
if options.testsuite:
init_tests(style)
return style.check_files()
-
-
-# nose should not collect these functions
-init_tests.__test__ = run_tests.__test__ = False