summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Cordasco <graffatcolmingov@gmail.com>2016-06-07 15:58:44 -0500
committerIan Cordasco <graffatcolmingov@gmail.com>2017-01-25 07:19:57 -0600
commit5a14978a3f6c1c8867b396d31491aa9cf073433c (patch)
tree83e4333851f992838092ec73fa225c88321054ed
parent10cefb702daf76e3916bdb924aaf0e593434f295 (diff)
downloadpep8-5a14978a3f6c1c8867b396d31491aa9cf073433c.tar.gz
Switch Travis to use tox
This reduces confusion about how travis runs tests versus a local developer. Unfortunately, pypy3 on Travis is stuck to a version that only implements Python 3.2. There is no convenient work around for that version so we remove it from our matrix until Travis updates their images.
-rw-r--r--.travis.yml39
-rw-r--r--tox.ini8
2 files changed, 29 insertions, 18 deletions
diff --git a/.travis.yml b/.travis.yml
index ee069e8..3847bde 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,23 +1,28 @@
language: python
sudo: false
-python:
- - 2.6
- - 2.7
- - 3.2
- - 3.3
- - 3.4
- - 3.5
- - nightly
- - pypy
- - pypy3
install:
- - pip install -e .
- - pip list
-script:
- - python pycodestyle.py --testsuite testsuite
- - python pycodestyle.py --statistics pycodestyle.py
- - python pycodestyle.py --doctest
- - python setup.py test
+ - pip install tox
+script: tox
+matrix:
+ include:
+ - python: 2.6
+ env: TOXENV=py26
+ - python: 2.7
+ env: TOXENV=py27
+ - python: 3.3
+ env: TOXENV=py33
+ - python: 3.4
+ env: TOXENV=py34
+ - python: 3.5
+ env: TOXENV=py35
+ - python: 3.6
+ env: TOXENV=py36
+ - python: nightly
+ env: TOXENV=py37
+ - python: pypy
+ env: TOXENV=pypy
+ - python: 3.5
+ env: TOXENV=flake8
notifications:
email:
diff --git a/tox.ini b/tox.ini
index 0c16e34..797bbfa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, py35, pypy, pypy3, jython
+envlist = py26, py27, py32, py33, py34, py35, py36, pypy, pypy3, jython
skip_missing_interpreters=True
[testenv]
@@ -14,3 +14,9 @@ commands =
{envpython} pycodestyle.py --statistics pycodestyle.py
{envpython} pycodestyle.py --doctest
{envpython} setup.py test
+
+[testenv:flake8]
+deps =
+ flake8
+commands =
+ flake8 pycodestyle.py