summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-06-03 09:25:17 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-06-03 09:25:17 -0700
commitf5be67cc842a3e0e02db130cde086f18929f656b (patch)
tree213199cb9fe0bdf4717cea356e563bdc86d18d7d
parent4538f43989a49aef163355cae44ebd686d1c780c (diff)
downloadpep8-f5be67cc842a3e0e02db130cde086f18929f656b.tar.gz
Document all supported Python versions as trove classifiers
I frequently use PyPI trove classifiers to check if a 3rd party package is usable by my projects. Documenting the supported versions makes this much easier for potential library users.
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b77770e..e68df56 100644
--- a/setup.py
+++ b/setup.py
@@ -51,7 +51,15 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries :: Python Modules',
],
test_suite='testsuite.test_all.suite',