summaryrefslogtreecommitdiff
path: root/CHANGES.txt
diff options
context:
space:
mode:
authorThomas Schultz <daspecster@gmail.com>2016-09-21 10:27:58 -0400
committerThomas Schultz <daspecster@gmail.com>2016-09-21 10:27:58 -0400
commite4244feabf24696ac00e74f1fb634f6e0d23277d (patch)
tree7c5aa847202f0171f09d185429dc2002979c84be /CHANGES.txt
parent1391c7e732fb8c1616a5b77243482c71d2644104 (diff)
downloadpep8-e4244feabf24696ac00e74f1fb634f6e0d23277d.tar.gz
Updated changelog from feedback.
Diffstat (limited to 'CHANGES.txt')
-rw-r--r--CHANGES.txt21
1 files changed, 5 insertions, 16 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index c514e47..953ece9 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -10,27 +10,16 @@ Announcements:
Changes:
-* Add Gitter badge; #557
* Report E302 for blank lines before an "async def"; #556
-* Updated tox to do same tests as Travis CI (`setup.py test`).
-* Updated to use sheilds.io badges.
-* Updated text about running tests with tox; #552
-* Update maximum_line_length to use Checker.noqa; 538
-* Updated Travis CI doc link.
-* Updated docs related to tested Python versions.
-* Added skip missing interpreters flag to tox config.
-* Add test-requirements.txt with basic test packages.
-* Report E742 and E743 for badly named functions and classes.
-* Also report E741 on 'global' and 'nonlocal' statements.
-* Report E741 for prohibited single-letter variables.
-* Added venv/ (virtualenv) to list of git ignored filename patterns.
+* Update our list of tested and supported Python versions which are 2.6 through 3.5 as well as the nightly Python build and PyPy.
+* Report E742 and E743 for functions and classes badly named 'l', 'O', or 'I'.
+* Report E741 on 'global' and 'nonlocal' statements, as well as prohibited single-letter variables.
Bugs:
-* Stop checking for string option type; #561
+* Fix opt_type AssertionError when using Flake8 2.6.2 and pycodestyle 2.0.0; #561
* Require two blank lines after toplevel def, class; #536
-* Badly named single-letter variable names are not detected; #341
-* Fixing compound_statement not to be quadratic in # of :s; #314
+* Remove accidentally quadratic computation based on the number of colons. This will make pycodestyle faster in some cases; #314
2.0.0 (2016-05-31)
------------------