summaryrefslogtreecommitdiff
path: root/CONTRIBUTING.rst
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-09-15 11:14:21 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2018-09-15 11:44:01 -0700
commit64c2e300cd1aed0abc82e75ed1139cc989c0e1b9 (patch)
tree4e1323bbf4a8c1bdfab679c88763ca63c533df2b /CONTRIBUTING.rst
parent566cdc0cb22e5530902e456d0b315403ebab980c (diff)
downloadpep8-64c2e300cd1aed0abc82e75ed1139cc989c0e1b9.tar.gz
Remove suggestion and documentation of using unmaintained nose
The nose project has ceased development. The last commit is from Mar 3, 2016. From their docs page: https://nose.readthedocs.io/ > Note to Users > > Nose has been in maintenance mode for the past several years and will > likely cease without a new person/team to take over maintainership. > New projects should consider using Nose2, py.test, or just plain > unittest/unittest2.
Diffstat (limited to 'CONTRIBUTING.rst')
-rw-r--r--CONTRIBUTING.rst14
1 files changed, 3 insertions, 11 deletions
diff --git a/CONTRIBUTING.rst b/CONTRIBUTING.rst
index 9f55859..f55c5e9 100644
--- a/CONTRIBUTING.rst
+++ b/CONTRIBUTING.rst
@@ -69,7 +69,6 @@ GitHub has an excellent `guide`_.
The current tests are written in 2 styles:
* standard xUnit based only on stdlib unittest
- (can be executed with nose)
* functional test using a custom framework and executed by the
pycodestyle itself when installed in dev mode.
@@ -77,19 +76,12 @@ The current tests are written in 2 styles:
Running unittest
~~~~~~~~~~~~~~~~
-While the tests are writted using stdlib `unittest` module, the existing
-test include unit, integration and functional tests.
+The tests are writted using stdlib `unittest` module, the existing test
+include unit, integration and functional tests.
-There are a couple of ways to run the tests::
+To run the tests::
$ python setup.py test
- $ # Use nose to run specific test
- $ nosetests \
- > testsuite.test_blank_lines:TestBlankLinesDefault.test_initial_no_blank
- $ # Use nose to run a subset and check coverage, and check the resulting
- $ $ cover/pycodestyle_py.html in your browser
- $ nosetests --with-coverage --cover-html -s testsuite.test_blank_lines
-
Running functional
~~~~~~~~~~~~~~~~~~