summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohann C. Rocholl <johann@rocholl.net>2009-10-02 14:36:04 -0700
committerJohann C. Rocholl <johann@rocholl.net>2009-10-02 14:36:04 -0700
commitb502820264c1fc33b5a2d511f0217c6674855641 (patch)
treecab6a147b683fb87c33dbcfa26fa72f06c1cd389 /Makefile
parent7e8583dd20bd4b9df1d5f2eeca4a2b0b7e9284f9 (diff)
downloadpep8-b502820264c1fc33b5a2d511f0217c6674855641.tar.gz
Support for all versions of Python from 2.3 to 3.1.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 887d567..11e86f8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,17 +1,24 @@
test :
python pep8.py --testsuite testsuite
-multitest :
- python2.4 pep8.py --testsuite testsuite
- python2.5 pep8.py --testsuite testsuite
- python2.6 pep8.py --testsuite testsuite
-
selftest :
- python pep8.py --repeat pep8.py
-
+ python pep8.py --repeat --statistics pep8.py
doctest :
python pep8.py --doctest
-
alltest : test selftest doctest
+
+multitest :
+ python2.3 pep8.py --testsuite testsuite
+ python2.4 pep8.py --testsuite testsuite
+ python2.5 pep8.py --testsuite testsuite
+ python2.6 pep8.py --testsuite testsuite
+ python3.0 pep8.py --testsuite testsuite
+ python3.1 pep8.py --testsuite testsuite
+ python2.3 pep8.py --repeat --statistics pep8.py
+ python2.4 pep8.py --repeat --statistics pep8.py
+ python2.5 pep8.py --repeat --statistics pep8.py
+ python2.6 pep8.py --repeat --statistics pep8.py
+ python3.0 pep8.py --repeat --statistics pep8.py
+ python3.1 pep8.py --repeat --statistics pep8.py