summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJohann C. Rocholl <johann@rocholl.net>2009-10-02 12:59:24 -0700
committerJohann C. Rocholl <johann@rocholl.net>2009-10-02 12:59:24 -0700
commit39a8e674b88ee7e7a8c5dbe9c3e9512f34590973 (patch)
tree90c3dae5085227cc5817ce235635e8df87ef53b5 /Makefile
parentfb2e83d37e5109811ab447b42811724157d457ef (diff)
downloadpep8-39a8e674b88ee7e7a8c5dbe9c3e9512f34590973.tar.gz
Moved test for different Python versions into Makefile.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 2abc74f..973ece9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,14 @@
+test :
+ python pep8.py --testsuite testsuite
+
+multitest :
+ python2.4 pep8.py --testsuite testsuite
+ python2.5 pep8.py --testsuite testsuite
+ python2.6 pep8.py --testsuite testsuite
+
selftest :
python pep8.py --repeat pep8.py
-test :
- python pep8.py --testsuite testsuite
+doctest :
+ python pep8.py --doctest