summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFlorent Xicluna <florent.xicluna@gmail.com>2012-03-26 02:09:51 +0200
committerFlorent Xicluna <florent.xicluna@gmail.com>2012-03-26 02:09:51 +0200
commitcba8f177ed560d25cebad65e86850d9c96c95b78 (patch)
treecf74e81d4ddd522f2fa670bf048e06f28cc0bb7a /setup.py
parentc7730e14159b0c171a08871db467073bc85e0442 (diff)
downloadpep8-cba8f177ed560d25cebad65e86850d9c96c95b78.tar.gz
Merge fixes for issues #34, #43 and #48.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 13 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index f9d25c4..8d79d58 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.6.0'
+version = '0.6.1'
long_description = '\n\n'.join([open('README.rst').read(),
open('CHANGES.txt').read(),
open('TODO.txt').read()])
@@ -9,7 +9,6 @@ setup(name='pep8',
version=version,
description="Python style guide checker",
long_description=long_description,
- classifiers=[],
keywords='pep8',
author='Johann C. Rocholl',
author_email='johann@rocholl.net',
@@ -28,4 +27,15 @@ setup(name='pep8',
'pep8 = pep8:_main',
],
},
- )
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+)