summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorreinout <reinout@vanrees.org>2009-08-31 14:00:58 +0200
committerJohann C. Rocholl <johann@rocholl.net>2009-10-06 08:51:01 -0700
commit061c39faa6ab7a7cbed9e9037b45fd8a5bfcbf86 (patch)
tree1f3233c4a683cb3e9ef06132223abc00ff15c89d /setup.py
parent21022f0a566db0fcdb47b2e5b31ba247b11432d1 (diff)
downloadpep8-061c39faa6ab7a7cbed9e9037b45fd8a5bfcbf86.tar.gz
Added setup.py to make it easy_installable. This allows upload to pypi.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..ac5e968
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+from setuptools import setup, find_packages
+
+version = '0.3dev'
+long_description = open('ANNOUNCE').read()
+
+setup(name='pep8',
+ version=version,
+ description="Python style guide checker",
+ long_description=long_description,
+ classifiers=[],
+ keywords='pep8',
+ author='Johann C. Rocholl',
+ author_email='johann@browsershots.org',
+ url='http://github.com/cburroughs/pep8.py/tree/master',
+ license='Expat license',
+ packages=find_packages(exclude=['ez_setup']),
+ namespace_packages=[],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+ 'setuptools',
+ # -*- Extra requirements: -*-
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'pep8 = pep8:_main',
+ ],
+ },
+ )