summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorreinout <reinout@vanrees.org>2009-09-14 11:10:54 +0200
committerJohann C. Rocholl <johann@rocholl.net>2009-10-06 08:57:09 -0700
commita8f07d18095f16d62285339fb6d7a2b26d38d65a (patch)
tree66bf1172cc0e259067e5172f0affb18a954b9edc /setup.py
parent3715b8ec9cbbd6fb1bd2269b4b284e7fa020cf52 (diff)
downloadpep8-a8f07d18095f16d62285339fb6d7a2b26d38d65a.tar.gz
Using py_modules instead of packages in setup() call as that is intended for single files.
Added manifest file for picking up changes.txt and todo.txt as distutils doesn't detect files in git
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3c06ee6..cae2cc1 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.3'
+version = '0.3.1dev'
long_description = '\n\n'.join([open('README.txt').read(),
open('CHANGES.txt').read(),
open('TODO.txt').read()])
@@ -15,7 +15,7 @@ setup(name='pep8',
author_email='johann@browsershots.org',
url='http://github.com/cburroughs/pep8.py/tree/master',
license='Expat license',
- packages=find_packages(exclude=['ez_setup']),
+ py_modules=['pep8'],
namespace_packages=[],
include_package_data=True,
zip_safe=False,