summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Sottile <asottile@umich.edu>2021-11-08 18:20:25 -0500
committerAnthony Sottile <asottile@umich.edu>2021-11-08 18:33:44 -0500
commit57802ace9f0a22fb303a2f5ba5f98b31cb8aadf8 (patch)
treec41d0a495027f1a62558e2cad44e04605c2cacee /setup.py
parentabc475ca09949aea9a802598c984bf822eea252f (diff)
downloadpep8-57802ace9f0a22fb303a2f5ba5f98b31cb8aadf8.tar.gz
manual: drop python 2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 1 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 3f0c363..b0b9efd 100644
--- a/setup.py
+++ b/setup.py
@@ -30,14 +30,9 @@ setup(
url='https://pycodestyle.pycqa.org/',
license='Expat license',
py_modules=['pycodestyle'],
- namespace_packages=[],
include_package_data=True,
zip_safe=False,
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
- install_requires=[
- # Broken with Python 3: https://github.com/pypa/pip/issues/650
- # 'setuptools',
- ],
+ python_requires='>=3.6',
entry_points={
'console_scripts': [
'pycodestyle = pycodestyle:_main',
@@ -50,10 +45,7 @@ setup(
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',