summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorAnthony Sottile <asottile@umich.edu>2020-03-24 11:48:32 -0700
committerAnthony Sottile <asottile@umich.edu>2020-03-24 15:43:22 -0700
commit8e7b671e34e6ed5dd2d4bf1c98459b542ee5a396 (patch)
treee294c8e2f034ea1059a5e7750b2b0605f5a3a74b /tox.ini
parent0e0b95883313b53d377c2df51349bf10d9571cfb (diff)
downloadpep8-8e7b671e34e6ed5dd2d4bf1c98459b542ee5a396.tar.gz
Instrument code coverage
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 9 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index fc42fc1..f4356a5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,19 +5,20 @@
[tox]
envlist = py27, py34, py35, py36, py37, py38, pypy, pypy3, jython
-skipsdist = True
skip_missing_interpreters = True
[testenv]
+deps = coverage
commands =
- {envpython} setup.py install
- {envpython} pycodestyle.py --max-doc-length=72 --testsuite testsuite
- {envpython} pycodestyle.py --statistics pycodestyle.py
- {envpython} pycodestyle.py --max-doc-length=72 --doctest
- {envpython} setup.py test
+ python -m pycodestyle --statistics pycodestyle.py
+ coverage run -m pycodestyle --max-doc-length=72 --testsuite testsuite
+ coverage run -m pycodestyle --max-doc-length=72 --doctest
+ coverage run -m unittest discover testsuite -vv
+ coverage combine
+ coverage report
[testenv:flake8]
-deps =
- flake8
+skip_install = true
+deps = flake8
commands =
flake8 pycodestyle.py