summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorIan Cordasco <graffatcolmingov@gmail.com>2016-06-07 15:58:44 -0500
committerIan Cordasco <graffatcolmingov@gmail.com>2017-01-25 07:19:57 -0600
commit5a14978a3f6c1c8867b396d31491aa9cf073433c (patch)
tree83e4333851f992838092ec73fa225c88321054ed /tox.ini
parent10cefb702daf76e3916bdb924aaf0e593434f295 (diff)
downloadpep8-5a14978a3f6c1c8867b396d31491aa9cf073433c.tar.gz
Switch Travis to use tox
This reduces confusion about how travis runs tests versus a local developer. Unfortunately, pypy3 on Travis is stuck to a version that only implements Python 3.2. There is no convenient work around for that version so we remove it from our matrix until Travis updates their images.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 0c16e34..797bbfa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, py35, pypy, pypy3, jython
+envlist = py26, py27, py32, py33, py34, py35, py36, pypy, pypy3, jython
skip_missing_interpreters=True
[testenv]
@@ -14,3 +14,9 @@ commands =
{envpython} pycodestyle.py --statistics pycodestyle.py
{envpython} pycodestyle.py --doctest
{envpython} setup.py test
+
+[testenv:flake8]
+deps =
+ flake8
+commands =
+ flake8 pycodestyle.py